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	Chapter 1. Introduction to GeoWRSI  
	


The GeoWRSI is a geospatial, stand-alone implementation of the Water Requirements Satisfaction Index (GeoWRSI), as implemented by the U.S. Geological Survey (USGS) for the Famine Early Warning Systems Network (FEWS NET) activity. The program runs a crop-specific water balance model for a user-selected crop in a user-specified region in the world, using raster data inputs. The program produces a range of outputs which can either be used qualitatively to help assess and monitor crop conditions during the crop growing season or regressed with yields to produce yield estimation models and yield estimates. In addition, the program has several tools for validation, enhancement and analysis of both input and output datasets. Other tools are available to post-process the water balance outputs so that they can be used for yield estimation.

Technically, the Water Requirements Satisfaction Index (WRSI) is the ratio of seasonal actual crop evapotranspiration (AETc) to the seasonal crop water requirement, which is the same as the potential crop evapotranspiration (PETc). Originally developed by the Food and Agriculture Organization (FAO), the WRSI has been adapted and extended by USGS in a geospatial application to support FEWS NET monitoring requirements. Yield reduction estimates based on WRSI contribute to food security preparedness and planning. As a monitoring tool, the crop performance indicator can be assessed at the end of every 10-day period during the growing season. As an early warning tool, end-of-season crop performance can be estimated using long-term average meteorological data. 

	Using this Manual
	


In this manual, there are several exercises and examples to familiarize you with the operations of the GeoWRSI. These exercises reference a sample dataset that you need to download and install on your computer. The dataset can be downloaded from ftp://hollywood.geog.ucsb.edu/pub/geowrsi/Samples.zip.
	Chapter 2. Installation
	


	System Requirements
	




The following specifications are needed on your computer to successfully install the GeoWRSI:
· Operating System:  

· Minimum: Windows 2000 or later 

· Recommended: Windows XP or later

· Microsoft .net Framework 2.0 Service Pack 1

The Microsoft .net Framework 2.0 Service Pack 1 can be downloaded from the GeoWRSI ftp site at ftp://hollywood.geog.ucsb.edu/pub/geowrsi/frameworkv2.0/ or from the Microsoft Web site.
	Installation Procedure
	




1. Double-click the file GeoWRSIv20beta.msi to start up the installation. During installation, it is recommended that you accept all the program defaults.

2. Run the program by going to the Start Menu and navigate to Start > Programs > GeoWRSI > GeoWRSIv2.
Notes
1. The GeoWRSI may fail to install if the computer you are trying to install it on does not have the Microsoft .net Framework 2.0 or later installed. To install the framework, on the installation CD, go to the frameworkv2.0sp1 directory and double-click the file NetFx20SP1_x86.exe. This will install the Microsoft .net Framework 2.0 Service Pack 1, which is required to run the GeoWRSI. This framework is also available on the Internet, and you can download it from the Microsoft Web site or the from the GeoWRSI ftp site at ftp://hollywood.geog.ucsb.edu/pub/geowrsi/frameworkv2.0/NetFx20SP1_x86.exe. 
 

2.  After this, the GeoWRSI can be run and the data files can be uploaded to it.

3. While you may be able to run some of the features of the GeoWRSI with the original Microsoft .net Framework 2.0, you will not be able to run many features correctly without the Microsoft .net Framework 2.0 Service Pack 1 installed. You should use the Service Pack 1 as indicated in the download links shown above.

	Chapter 3. Preparing to Run the GeoWRSI for the First Time
	




When you run the GeoWRSI for the first time, you will be prompted to select the default region for which you want to run the water balance model. The program comes with five regions for Africa and one for Central America. If your analysis is for one of these regions, then select the region from the options that are listed. You do not need to read the rest of this section if you are running one of these regions.

If you do not intend to run the model for one of these regions, select one of the regions anyway so that the installation can complete. After this, you can edit one of the existing regions, create a new region, or import an existing region and modify it to fit your computer. More descriptions on the nature of GeoWRSI region files can be found in GeoWRSI Regions explained in the help system.

Editing an existing region:
To edit an existing region, use the menu bar to go to File > Edit > Region.
You will be prompted to select the region that you want to edit. Select the region that is most like the region you want to create (for example, same season or spatial area covered).
Edit the region to your satisfaction, then click the "Save As" button and specify a new region name.

Creating a new region:
To create a new region, use the menu bar to go to File > New > Region.
Follow the steps outlined in the help system topic "Running the Model for Other Regions." 

Importing a region
If the region you want to use already exists (you may have downloaded it from the GeoWRSI Web site, you can import the region into the GeoWRSI using the menu commands File > Import > Region file. The GeoWRSI Web site is http://chg.geog.ucsb.edu/wb/geowrsi.php, and it may have some regions that you are looking for. 

Note about importing regions
If you are going to import a region, make sure that you have all the files that are referenced in the region file, and then modify the paths in the region file so that they accurately reflect the correct path on your computer.
You will have to implement several other procedures the first time you run the water balance model, including loading the data files into the GeoWRSI, selecting which files you want to save, setting up the water balance model to run in the manner you specify, and running the model itself. This chapter explains the procedures in detail.


	Loading the Data Files
	




The GeoWRSI does not automatically install the precipitation files and the evapotranspiration files that are needed to run the model. Instead, you need to install the files corresponding to those years you want to use. For example, suppose you want to run the model for the 2003–2004 season in southern Africa. You need to upload these data into the GeoWRSI first.

Precipitation Data Requirements for Running the Model

To run the program successfully, you need to have current data encompassing at least the beginning of the period described by your region file. In addition, you also need six previous dekads of information before it starts, mainly to initialize the soil moisture. For instance, if the season starts on dekad 25 of the year, the model starts building up the soil moisture from even earlier (dekad 19). If your region file specifies that the season start in dekad 4 of the year, then you need dekad 34 of the previous year to dekad 3 of the current year as initialization dekads. So if you want to run the model for 1996, you will need to have at least dekad 34, dekad 35, and dekad 36 of 1995 and dekad 1 to 3 of 1996 for the model to run.

Where to Get the Data

You can get the data from the following sources:

1. From the installation CD in the Data Archives directory or by downloading the data from the GeoWRSI data archives folder on the ftp site at ftp://hollywood.geog.ucsb.edu/pub/geowrsi/archives
2. From the program Web site at http://chg.geog.ucsb.edu/wb/geowrsi.php
3. From the Africa Data Dissemination Service (ADDS) rainfall estimate (RFE) files that are available on the ADDS Server

4. By using the direct download facility within the GeoWRSI, located under the Tools menu 

Accessing the Latest Data
Historical archives are available for all of Africa from 1996 to 2007. In addition, the latest data are updated every 10 days on the ADDS Web site, at least for Africa precipitation and global evapotranspiration. Users can download the latest data available from the Web site using the Download tool available on the GeoWRSI. You can also import the data from the ADDS RFE files that are available on the ADDS server.

You can use the options found under the menu item Tools > Download from Web. 

To ensure that the latest data is automatically loaded whenever it is available, click the menu item Tools > Download From Web > Automatic Daily Download.


To download a range of dekads of available data, click Tools > Download from Web > Download Data By Date. Select the dates that you want to download (by default, the last program selects the latest dekad for you, but you can change this) and click OK. The GeoWRSI will download the evapotranspiration (PET) or precipitation (PPT) data for the dates that you specified if they are available on the GeoWRSI site.

For more information on the options available within this facility, see the next topic, Downloading directly into GeoWRSI.
Loading the Data into the GeoWRSI
Once you have gotten the data archives onto your computer, you need to load the data files into the GeoWRSI, and the process is outlined below.

1. On the File Menu, navigate to File > Import. 
· To load the PPT data, click GeoWRSI PPT archive to data directory.

· To load the PET data, click GeoWRSI PET archive to data directory.
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2. Select the files you want to load. 

· These files will have a .gp2 extension for the precipitation archives and a .ge2 extension for the evapotranspiration archives. 
· You can load as many files as you need at a time. 
· When you have selected the file, click the “Open” button. 
· The program will ask you to wait as it is processing the files and will indicate when it is finished by the word "Done." You may have to scroll down to the end of the processing console to see that the files have finished processing. Wait for the program to finish processing.
Notes
If you are running the model for a region outside of Africa or Central America, you will have to import the long-term average precipitation and evapotranspiration for your region. This can be done using the same process described above. The GeoWRSI comes with long-term average precipitation and evapotranspiration files for Africa and Central America, and these files have to be overwritten with files from your region of interest if the program is to run properly. However, if you are running the model for Africa or Central America, this last step of importing the long-term averages is not necessary. For more information, see Loading up PPT and PET historical averages.
	Downloading directly into the GeoWRSI
	




The help topic "Loading the data files" describes various methods of getting data into the GeoWRSI. One of these methods is downloading data directly into the GeoWRSI. 

How the Download directly method works
Clicking the menu sequence Tools > Download From Web > Download Data By Date causes the GeoWRSI to connect to the ftp server that contains data archives and the latest data. With this method, the data are downloaded and loaded in one procedure, all from within the GeoWRSI user interface. Only certain data are currently available by download:

· global evapotranspiration estimates data for the latest calendar year  

· Africa-wide rainfall estimate data for the latest 3 years

Requirements
Internet connection (the computer running the GeoWRSI must be connected to the Internet for this operation to be carried out).
Procedure
1. Go to Tools > Download From Web > Download Data By Date
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Specify the range of dates over which you want to download the data. The program may take some time connecting, but if the data are available, the program will download the data and report its progress. You may have to scroll down the progress console to see the progress.
Downloading from other FTP sites and regions
By default, the settings for the download facility are configured so that the downloads for rainfall are for Africa rainfall data and global PET. However, you can tweak advanced settings so that you point the program to download from a different server. These settings are found in the GeoWRSI Data and Settings Directory, in a file called ftpdataregion.txt. You can access this directory by clicking on the Windows Start Menu at Start > All Programs > GeoWRSI > Tools > GeoWRSI Data and Settings, then opening ftpdataregion.txt. Only access this file if you are not running a region for Africa. The dataregion that has the text DEFAULTREGION next to its name is the one that the GeoWRSI will download. Currently, the program can only process (for importing) data in albers and geographic projection.
	Viewing Available Files
	




To perform a WRSI water balance model run, various input data, including precipitation and evapotranspiration, must be available for the process to run. These data must be present on the computer on which the GeoWRSI is installed in the GeoWRSI directory. After having acquired the data as described in the sections on loading data and downloading data, you may want to check what data are available in the GeoWRSI system. This will be useful to see if you can run data for a specific season and which extra data you need to get.

Viewing which data are available
This function can be accessed under the Tools > View Available Data menu. 
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When the dialog box below appears, select either Precipitation or Evapotranspiration, then click on the "View Data List" button
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You can also check which data is missing between the first and last available data on your system by clicking on the button "List Missing Data"

What to do if the required data are not available
If the data that you require do not appear in the Available Data list, then you will have to load the data files or download directly into the program.
Notes
Precipitation and evapotranspiration are just some of the input data that are required by the GeoWRSI water balance modeling process. The other inputs include climatological start of season (SOS), climatological WRSI, length of growing season of the crop, a mask file, and an SOS color file. These other inputs are all specified in the region file. For more information, see the help topic Inputs to the Model and getting more information about the region files.

	Saving the GeoWRSI Output
	




It is useful to know how to save the outputs of the GeoWRSI before you run the water balance model, because some of the methods for saving the file have to be defined before you start running the model.

Setting the output folder
First, you need to decide where the output files created by the GeoWRSI are going to be saved. By default, the GeoWRSI saves to the folder c:\geowrsi\output\, which is created when you install or run the program for the first time. To change the output folder, click the menu item Setup > WRSI Output Folder > FolderName ("foldername" is the name of a folder that you will see when you navigate this menu item).

Click the <FolderName>, select a directory, and click OK. If you go to Setup > WRSI Output Folder again, you will see that "FolderName" will now be the folder that you just selected.

Selecting which GeoWRSI outputs to Save
GeoWRSI creates over 40 different outputs, and not all of them have to be saved. You can choose which outputs you want to save by using a number of different methods. 

There are 5 ways in which you can save the output from the GeoWRSI. We will go through these 5 ways below. 

On the menu, you can click File > Define Output Options. This will take you to a dialog box that allows you to specify before you start running the model which outputs to save 


[image: image5]
There are several options on this dialog box, which allow you to decide:

· which files should be saved

· at the current dekad,

· at the forecast harvest time,

· which files should be saved every dekad,

· which specific dekad all the files should be saved,

· whether to export all outputs to Windisp format for further analysis, and

· whether the crop-stage totals (totals at initial, vegetative, flowering and ripening stage) should be saved.

· which folder to save the outputs to

· whether the outputs should have descriptive text written on the, and the level of detail of the descriptive text.

1. Instruct program 'Which outputs to Save at the Current Dekad'
The current dekad is the last dekad for which you have current rainfall data. The program starts scanning the time-series of avalilable rainfall data from the time the program initializes. If it finds a dekad for which there is no rainfall data, the program assumes that the dekad before the "no-data-dekad" is the latest, or current dekad, because that was the last dekad with data available.  assumes that if there is a data in the GeoWRSI archive after this (current) dekad, then it must be because no data was observed after this dekad, and in turn, this must be because all the “missing data” is for events that are in the future and have not yet been recorded. Therefore, this dekad must be the one which we are currently.
To specify which outputs to save at the current dekad, change the "Current Dekad Outputs" section in the dialog box show above
· The parameters described here include  WRSI,  WRSI Anom,  % LGP etc (see figure above).  
· If a parameter has a tick against it (e.g. WRSI” in the figure above), it will be saved during the model run. 
· If it does not have a tick, it will not be saved. 
· Click “Select All Current Outputs” if you want to save all the parameters listed at the current dekad section 
· Click “Click Deselect All Current Outputs” if you don’t want to save any of the Current parameters.
2. Instruct program 'Which outputs to Save at the End of Season'
This Section is quite similar to Current Dekad section, and is found in the "End of Season Dekad Outputs" section except that the files that will be saved will indicate the status of the model outputs at the end of the growing season. Even when the data is not available to the end of the season, an extrapolation is done using climatological data once the dekad with available current rainfall data is reached.This estimation is done by using long-term average rainfall and average PET as estimates for rainfall and evapotranspiration that has not yet occurred.
 To specify which outputs to save at the End-of-season dekad, change the "End-Of-Season Dekad Outputs" section in the dialog box show above 

3. Instruct program which 'Outputs to save at every dekad'
With this instruction, all of the outputs of the type specified will be saved each dekad throughout the model run. So for example, if the model runs from dekad 4 to dekad 20, each WRSI, phenology, and/or soil water image will be saved

 To specify which outputs to save at every dekad, change the "Outputs to save at every dekad" section in the dialog box show above. If there is a tick against the output, it will be saved for each dekad, if there is no tick, it will not be saved. Click on the output to select or de-select it.
4. Instruct program to 'Save all the parameters at a specific Dekad'
If there is a dekad which you think is important in the phenological cycle, and you wish to examine what was the state of the water balance at this particular dekad, you may want to save all the water balance parameters at this dekad for more detailed analysis later. There is an option in the dialog box above with the text "Save all files at given dekad". Click on this option to activate or de-activate this option. When the option is active, you need to specify which dekad to save all the outputs.
4. a. Instruct the program whether to Save Crop Stage Totals or not
Click the option "Save crop stage totals at end of season" to instruct the program whether to save the crop stage totals or not. This allows you to save the crop stage totals of water deficit, water surplus, and water requiremnt and actual evapotranspiration at the initial, vegetative, flowering and ripening stages of the crop
5. The fifth way to save the output is done while the model is running.
· While the model is running, you can choose to advance the model one dekad at a time. 
· Using the tab controls, you can view the different outputs at each dekad. 
· If you see one output, and you would like to later reference the value of that output at the dekad the program is currently at, you can click the Save button (highlighted in the Figure below). 
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Notes
· To advance the model one dekad at a time, press the Play button, [image: image7.png]


, or go to the menu item WRSI > Advance One Dekad
· The current dekad is the one before the first instance of missing data for a dekad. Unfortunately, even if there are gaps in the data time-series, and there is data after the gap, the program will still assume that the last dekad before the gap was the current dekad, and it will use average data after that. That is why it is important to ensure that there is no missing data in the time series.
	Setting Up the WRSI Model Run 
	




The menu item Setup allows you to configure the water balance model run and set the various parameters that will determine exactly how the water balance model is run. The settings that you can change include

· The geographical/seasonal region for which to run the model 

· The crop type to model 

· The definition of the Growing Period of the crop 

· The definition of the Start of Season 

· The definition of the Water Holding Capacity 

· The definition of the Mask 

· The type of precipitation to use in the modeling (whether climatological or current precipitation should be used) 

· The type of evapotranspiration to use in the modeling (whether climatological or current precipitation should be used) 

If you are not satisfied with the water holding capacity (WHC), SOS, or length of growing period (LGP), there are different ways of modifying them. You can use the Image > Start Editing menu to edit them pixel by pixel, or you can import them from vector files as described in the subtopics in this chapter.

You can also define these options:

· When to stop an automated WRSI Run 

· The directory where the outputs should be saved 

· Whether to add a prefix to all the outputs for that run

These settings are all available by clicking the Setup menu as shown below.

[image: image8]
Information for each of these Setup items is available in greater detail in the help system.

	Chapter 4. Running the GeoWRSI Water Balance Model
	




The steps for running the model are outlined below.


1.  Initialize the model for the year you wish to run.
· Use the menu item WRSI > Initialize, or 

· Use the toolbar button [image: image9.bmp].

[image: image10]

2. You will be presented with an input box.


[image: image11]

Specify the year in which the season of interest starts, then press enter or click OK.

3. You will be presented with a progress bar to show the progress of the initialization. Wait for this process to complete. When it is complete, the program will show you a message box informing you the dekad of the end of the season, where the model will stop running.

[image: image12]

4. Once the initialization is complete, you can advance the model run by one dekad or run until the end using the play and fast-forward buttons on the toolbar or the WRSI menu item. Several functions are available while you are running the model, and more information on these is available under the topic Functions Available While Running the Water Balance Model.

Running the model to the end of the season
Your region file will specify that the season runs from dekad x to dekad y (for example, from dekad 4 to dekad 27). If the start-of-region-season is less than the end-of-region-season, then the program assumes that the season runs within the same year. Otherwise, if the start-of-region-season is greater than the end-of-region-season, then the program assumes that the season runs from one year to another (for example, if the region file specifies that start is from dekad 25 and end is at dekad 15, then the program assumes that the season runs from dekad 25 of one year to dekad 15 of the following year).

Note:
The seasonal parameters found in the region file are only general guidelines. The model is limited to start no earlier than the SOS indicated in the region file, but it can go on until after the end of season (EOS) indicated in the region file. The model actually runs until SOS + LGP completes for every pixel. Suppose your region file indicates that the season is from dekad 5 to dekad 30. Then suppose that your longest LGP is 18 dekads. Suppose further that there are some spurious pixels (in this long LGP area) where start of season was only detected in dekad 17 of the year (due to bad rainfall patterns, for instance). Then the model will run until the last pixel has completed its cycle, which will be dekad 35 (18lgp + 17sos = 35). If you look at the %lgp map while you run the program, you will find that most of the pixels will complete their cycle (brown color) long before the last date of running. This happens to avoid a program termination that causes the crop to look healthier than it really should look at the end of its season, and to allow the crop to die a natural death.
	Functions Available While Running the Water Balance Model
	




Several functions are available while running the GeoWRSI model. These can be grouped as follows: 

· Model advancement control 

· Zooming  

· Product viewing 

· Saving products 

· Adding and removing maps

All of these functions can be accessed from either the menu bar or the toolbar, and the methods of accessing these functions are described in mode details below. Before we describe each of these functions in detail, it is useful to look at the toolbar a little closer. 

The GeoWRSI Toolbar
The toolbar has been specifically set up to provide the model advancement, zooming functions, and saving products functions. In summary, the tools available from the toolbar, all of which can be used during the model run, are outlined in the schematic below.


[image: image13]

We will now describe in detail each of the functions available while running the model. 

Model advancement control
The model advancement functions allow you to

· Advance the model by one dekad 

· Automatically Run the model to the end of the season 

· Stop the automatic run-to-end-of-season 

· Initialize a new water balance run 

· Cancel the current water balance run

The first three model advancement functions listed above (advance one dekad, automatically run to end, and stop automatic run) can be accessed from the toolbar. These functions allow you to control the pace at which you want to run the model.

The Initialize function, if you press it while the model is running, will cancel the current water balance run and initiate a new run.

The function for cancelling the water balance run will cause the water balance model to stop, and all the model parameters will be reset. This enables all the setup options that were disabled during the model run and allows you to change some of the settings such as LGP and SOS (these settings cannot be changed while the model is running).
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All of these functions are available under the WRSI menu item (for example, WRSI > Cancel Water Balance Run will cancel the current water balance run), but they are only available while the water balance model is running (when the model has been initialized); otherwise, they are disabled at all other times.


Zooming
While the model is running, the zoom functions that are available include

· Zooming in  

· Zooming out 

· Zoom to a user-specified rectangle 

· Panning (keep the same zoom level but centering the image on a point clicked by the user) 

· Zoom to region extent (zoom to the entire extent of the currently active region)

These functions are all illustrated on the toolbar schema in the graphic above.

Product Viewing 
The products and inputs of the GeoWRSI are viewed using the tabs. The tabs are highlighted in red in the graphic below. You can click on the different tabs to view the different products even while the water balance model is running.
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To view any of the products or inputs, click on the tab for that product. When you click on the tab, it becomes raised above the other tabs, and its image is the one that becomes visible in the map area on the GeoWRSI. In the example above, the WRSI tab is the one that is active, and it looks a little higher than the other tabs. The WRSI map and legend are visible.

Saving Products
Some of the GeoWRSI products can be saved while the GeoWRSI model is running. By pressing the Save button on the toolbar (illustrated on the toolbar schema in the diagram on the toolbar section of this topic), the GeoWRSI will save whatever tab is active (see the "Product Viewing" section above) at that time. 

Any saved products will be saved to the output folder, which can be set using the menu item Setup > WRSI Output Folder > ...FolderName... 

While the model is running, you can decide which outputs should be saved at current dekad, end of season, or at any other dekad. Find more information on this, and on setting the output folder, under the topic Saving the GeoWRSI Outputs.

Note that the inputs PPT and PET will not be saved by pressing the Save button because they already reside on the computer in the GeoWRSI data directory. To access this directory, you can go to the Windows Start Menu and click Start > All Programs > GeoWRSI > Tools > GeoWRSI Data and Settings. 

Adding and removing maps
You can add or remove vector maps of your choice to enhance the view. These maps may be in shapefile or BNA format. The menu path for adding maps is Map > Add Map, the menu command for removing a map is Map > Remove Map.

More detailed explanations on these commands are available under the help topic Adding and Removing Vector Maps from the GeoWRSI Display.

Note: Functions NOT available while running the model
Some functions are disabled once the water balance model has started running to prevent the user from changing the configuration halfway through the model run, which would produce unpredictable and unreliable results. The following items under the Setup and File menus are disabled once the water balance model has started running.
· Region configuration and editing 

· Crop selection and editing 

· LGP configuration 

· SOS configuration 

· WHC configuration 

· Mask configuration 

· Precipitation and evapotranspiration configuration
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Primary Outputs
The water balance model produces several model outputs that allow for various monitoring and yield estimation activities. The primary output of the model is the WRSI, the program's namesake. The WRSI, or water requirements satisfaction index, is the ratio between the amount of water available to the crop compared to the amount of water required by the crop. More detailed information on the model is available under the topic Calculating WRSI.

The full range of products available from the GeoWRSI is listed below.
Full list of Program Outputs
· WRSI 
· WRSI Anomaly  
· Start of Season  
· Start of Season Anomaly 

· Phenology (percentage of LGP)
· First wilting date

· Second wilting date
· Soil Water Index

· Total Actual Evapotranspiration at different stages of crop growth 
· Total Water Deficit at different stages of crop growth 
· Total Water Requirement at different stages of crop growth 
· Total Surplus Water at different stages of crop growth 
· Maximum Water Deficit experienced in any one dekad 
· Maximum Surplus Water experienced in any one dekad 
In addition, outputs are classified in such a way that they are saved either at the current dekad to become current outputs or at the end of the season to become extended outputs. They are called forecast outputs if the season being modeled does not have a full dataset. The two terms are defined below.
1. Current water balance conditions
These products portray water balance conditions for a particular crop at the present time period. The GeoWRSI estimates the "present time period" as the last date of continuously available data. If there is a gap in the data, that will be taken as the "Current dekad" because that is when the continuous data ends. Therefore, running the model for previous years that are fully stocked in data will not result in a current dekad because all the data will be available for those seasons.The current water balance conditions are based on the actual estimates of meteorological data to date. The most common Current Water Balance Product is the Current WRSI, which portrays WRSI conditions from the start of the growing season until the present time period.
2. Extended or end of season water balance conditions
For currently unfolding events in which the precipitation data do not run to the end of the season, this product is a forecast estimate of water balance conditions at the end of the growing season. Long-term average climatological data are used to calculate water balance conditions for the period between the current dekad and the end of season. The calculation principles are the same as the “Current water balance products, except that long-term average climatological data are used where current data are no longer available.

Where the full current precipitation dataset is available for the season being modeled, this product shows end of season water balance conditions. 

The long-term average PET and rainfall is extracted from FAO’s (1961–1990) long-term average monthly data (M. Bernardi, personal communication). Note that at the end of the growing season, only current-year PET and PPT are used as input. The most common Extended or End of Season Water Balance Product is the Extended WRSI or End of Season WRSI.


File naming conventions of the GeoWRSI outputs
Each of the GeoWRSI outputs is put in the GeoWRSI output folder and is named in a very specific way so that the user can recognize what type of file it is from the filename. The file naming convention for each of these outputs is described under the next topic Understanding the GeoWRSI output files.
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WRSI 
WRSI stands for Water Requirements Satisfaction Index. It is the ratio between the amount of water available to the crop compared to the amount of water required by the crop. More detailed information on the model is available under the help topic Calculating WRSI.

WRSI Anomaly  
The WRSI anomaly image compares the WRSI to (as percentage) the climatological (normal or median) WRSI image specified in the region file. An anomaly of 200 means that the WRSI for the season being modeled is twice the climatological WRSI, whereas a WRSI anomaly of 50 means that the current season's WRSI is half the climatological.

Start of Season 
The start of season image indicates the dekad when the season starts. The pixel values are in dekads between 1 and 36. There are several ways of calculating the start of season image, and these are detailed in the help topic Calculating Start of Season. In the default operational WRSI, the start of season is approximated using the rainfall accounting method. That entails tracking three consecutive dekads: if there is 25 mm or more in one dekad and 20 mm or more in the next two dekads, that is considered a start of season. However, if this criterion is met more than three dekads before the climatological start of season, then a start is not registered, and the algorithm keeps searching.

Start of Season Anomaly 
The start of season anomaly image is the start of season compared to (by subtraction) the climatological start of season image specified in the region file. The anomaly image indicates whether the current season image was at the same time as, earlier than, or later than the climatological start of season, in number of dekads

Phenology (percentage of LGP, or season progress)
The phenology, or season progress, map shows the percentage of the LGP that has already passed by at each pixel. The phenology ranges from 0 to 100 percent, whereby 0 percent means the crop has not yet started, and 100 percent means the crop has finished growing.

First wilting date
The first wilting date is the first dekad at which any wilting occurs. The pixel values are in dekads between 1 and 36. This product is only useful if the program is configured to search for a new start of season after crop failure occurs.

Second wilting date
If wilting occurs more than once at any pixel, this image shows the date at which the second wilting occurs. The pixel values are in dekads between 1 and 36. This product is only useful if the program is configured to search for a new start of season after crop failure occurs.

Soil Water Index
The soil water index image represents the amount of water stored in the soil up to crop root depth as a percentage of the WHC of the soil at the end of a particular dekad “i”, where SW is soil water content and “i” is the time step index.


Total Actual Evapotranspiration at different stages of crop growth 
This product measures total actual evapotranspiration of the crop accumulated over specified time periods. Each dekad, the crop evapotranspires a certain amount of water. This amount may differ from dekad to dekad. This amount of water (actual evapotranspiration) is equal to the water requirement of the crop limited by the amount of water available. For example, if the crop requires 50 mm of water in a specific dekad but only has 40 mm available to it, the actual evapotranspiration will be 40 mm. If the crop requires 50 mm of water and has 70 mm of water available to it, the actual evapotranspiration will be 50 mm, because it will not take more than it needs. The GeoWRSI presents the total actual evapotranspiration accumulated for different intervals. The five different intervals over which the actual evapotranspiration is accumulated are as follows:

· Total actual evapotranspiration accumulated over the entire growing season 

· Actual evapotranspiration accumulated over the initial stage of the crop 

· Actual evapotranspiration accumulated over the vegetative stage of the crop 

· Actual evapotranspiration accumulated over the flowering stage of the crop 

· Actual evapotranspiration accumulated over the ripening stage of the crop


Total Water Deficit at different stages of crop growth 
This product measures the total water deficit accumulated over specified time periods. In the water balance model, the crop requires a specific amount of water each dekad (this amount differs from dekad to dekad). If the crop has less water available to it than the amount it requires, then it experiences a deficit, which is called the water deficit. Suppose that the crop requires 50 mm in a dekad, and it only had 40 mm of water available to it. It will have a water deficit of 10 mm. 

The GeoWRSI presents the total water deficit accumulated for different intervals. The five different intervals over which the total water deficit is accumulated are as follows:

· Total water deficit accumulated over the entire growing season 

· Water deficit accumulated over the initial stage of the crop 

· Water deficit accumulated over the vegetative stage of the crop 

· Water deficit accumulated over the flowering stage of the crop 

· Water deficit accumulated over the ripening stage of the crop


Here is an example of how total water deficit for the entire growing period is accumulated: suppose that in a particular pixel, the following water deficits were experienced dekad by dekad for nine consecutive dekads during the season: 0, 0, 11, 2, 7, 15, 34, 1, 4. The total water deficit in this case will be 0+0+11+2+7+15+34+1+4=74

Total Water Requirement at different stages of crop growth 

This product measures the total water requirement of the crop accumulated over specified time periods. Each dekad, the crop requires a certain amount of water. This amount may differ from dekad to dekad. The GeoWRSI presents the total water requirement accumulated for different intervals. The five different intervals over which the total water requirement is accumulated are as follows:

· Total water deficit over the entire growing season 

· Water deficit accumulated over the initial stage of the crop 

· Water deficit accumulated over the vegetative stage of the crop 

· Water deficit accumulated over the flowering stage of the crop 

· Water deficit accumulated over the ripening stage of the crop

Total Surplus Water at different stages of crop growth 
This product measures the total water surplus accumulated over specified time periods. In the water balance model, the soil can only take in a limited amount of water, the soil's WHC. If the soil receives more water than it can hold at any given time, that water may become runoff, or it may become ponded, depending on the terrain and other local characteristics. This water that cannot be taken in by the soil is called the surplus water. Suppose that the soil in a certain location can only hold a maximum of 150 mm of water. Suppose further that the soil already contains 120 mm of water, and then a rain event releases 50 mm of water. The soil will only be able to take in 30 mm, at which point it will reach capacity, and the other 20 mm will be surplus water. 

The GeoWRSI presents the total surplus water accumulated for different intervals. There are five different intervals over which the total surplus water is accumulated, which are as follows:

· Total surplus water over the entire growing season 

· Surplus water accumulated over the initial stage of the crop 

· Surplus water accumulated over the vegetative stage of the crop 

· Surplus water accumulated over the flowering stage of the crop 

· Surplus water accumulated over the ripening stage of the crop


Here is an example of how total surplus water for the entire growing period is accumulated: Suppose that in a particular pixel, the following surplus water was experienced dekad by dekad for nine consecutive dekads during the season: 0, 0, 51, 3, 0, 15, 73, 0, 5. The total water surplus in this case will be 0+0+51+3+0+15+73+0+5=147

Maximum Water Deficit
This product is the maximum water deficit experienced in any single dekad through the growing season. For example, suppose that in a particular pixel, the following water deficits were experienced dekad by dekad for nine consecutive dekads: 0, 0, 11, 2, 7, 15, 34, 1, 4. The maximum water deficit in this case will be 34.

Maximum Surplus Water
This product is the maximum water surplus experienced in any single dekad through the growing season. For example, suppose that in a particular pixel, the following surplus water was experienced dekad by dekad for nine consecutive dekads during the season: 0, 0, 51, 3, 0, 15, 73, 0, 5. The maximum water surplus in this case will be 73.
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The GeoWRSI water balance model produces several outputs that are placed in the GeoWRSI output folder and can be viewed later. These outputs include image files (maps) that can be viewed in a GIS package and have other layers added for context or other analysis, and graphic files. Each of the water balance products is given a filename that allows the user to know what type of file it is. 

The first part of the filename is usually a "w" to indicate that this is a water balance product. The first part of the file may also have a user-specified prefix before the "w" (users can specify this prefix to help them differentiate between different model runs that used different settings).

The second part of the filename usually indicates the year that the WRSI run started (if the file has an "_e" or a "_c" at the end—this will be explained later), or the dekad that the file was saved, which will be the dekad for which it is valid.

The third part of the filename indicates the type of product, normally using two letters. For instance, "do" is for the WRSI, and "dt" is for the SOS. 

The last part of the filename indicates whether the image is for the current dekad or the end of season, where valid. This is indicated by "_c" or "_e," respectively.

Finally, the extension indicates the type of file it is. For most outputs, four or five different kinds of files are produced:
· ".bil" file is the image file that can be viewed in GIS programs like ArcView.
· ".hdr" file is the header for the image file. It needs to be used together with the ".bil" file.
· ".clr" file is the color file that can be used with the image file to simplify the viewing process in some programs like ArcGIS. 

· The user can also opt to produce Windisp files. These will have the extension ".img" or ".iml." 

· ".png" is a graphics file that can be viewed by double clicking. It is not a GIS file and cannot be overlaid with other maps.


For example, the file w2006do_e.bil is the WRSI ("do") for 2006 at the end of the season ("_e")

Naming conventions for the GeoWRSI outputs
The naming conventions for the full list of outputs are given below

md: 

maximum water deficit experienced in any single dekad through the growing season

mx: 

maximum water surplus (excess) experienced in any one dekad through the growing season 

dl: 

percentage of the crop’s cycle length that has occurred (100 percent at end of season)

dt: 

start of season 


dd:
start of season anomaly image 

do: 

water requirement satisfaction index (WRSI)


er:
WRSI anomaly image 

td: 

total water deficit throughout the growing season

te: 

total evapotranspiration throughout the growing season

tr: 

total water requirement throughout the growing season


w1:
first wilting date

w2:
second wilting date

id: 

total water deficit during the initial stage of the crop

vd: 

total water deficit during the vegetative stage of the crop

fd: 

total water deficit during the flowering stage of the crop

rd: 

total water deficit during the ripening stage of the crop

ie: 

total actual evapotranspiration during the initial stage of the crop

ve: 

total actual evapotranspiration during the vegetative stage of the crop

fe: 

total actual evapotranspiration during the flowering stage of the crop

re: 

total actual evapotranspiration during the ripening stage of the crop

ir: 

total water requirement during the initial stage of the crop

vr: 

total water requirement during the vegetative stage of the crop

fr: 

total water requirement during the flowering stage of the crop

rr:

total water requirement during the ripening stage of the crop

ix: 

total water surplus experienced during the initial stage of the crop

vx: 

total water surplus experienced during the vegetative stage of the crop

fx: 

total water surplus experienced during the flowering stage of the crop

rx: 

total water surplus experienced during the ripening stage of the crop


End of season and Current Dekad products
The end of season and current dekad products are signified by the last part of the filename, "_e" and "_c," respectively. These are explained below:

_e
signifies that the file was saved at the end of the season after the crop had finished growing (the time when the WRSI is at the "extended WRSI" period (as defined by the growing parameters (is, SOS + LGP))

_c
signifies that the file was saved at the current dekad, thereby capturing the status of the water balance at the current dekad. The current dekad is the last dekad for which current data is available.

Some Examples: using _e

The "_e" means that these files were saved at the end of the growing season. For example, do_e is the extended or end of season WRSI, since it is WRSI at the end of the growing season. As another example, td_e is the total water deficit through the growing season up to the time of the end of the season, and md_e is the maximum water deficit experienced by the end of the growing season.
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This section introduces some of the more advanced operations that are possible in the GeoWRSI and emphasizes operations that can modify the running or the viewing of the water balance model and results. In particular, the following operations are introduced:

· Creating and adding a mask to the water balance model to exclude areas outside the study area of interest 

· Adding and removing vector maps to the water balance run to enhance contextual viewing 

· Using field-based planting and crop-cycle length information 

· Running the model for other crops 

· Running the model for other regions 

· Resetting the regions back to their original/default settings 
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The mask file is a raster bil file that has a value of 1 in areas that should be shown on the map and a value of 0 in areas that should be masked out. The bil file should be in geographic projection. Only pixels with a value of 1 will be displayed through the mask—all other values will be masked out. The mask only applies to raster data; vector data will show through the mask. 

If such a mask already exists, it can be applied by specifying that the program should not use the default mask file but a selected mask file. To do this:

· On the menu bar, go to Setup > Mask Def > Select Mask File   

· Select the bil file that you want to be used as a mask file

A second way of changing the mask file is making the appropriate changes in the region file so that the mask file specified will be the default mask file for a given region. To do this:

· On the menu bar, go to File > Edit > Region
· Select the region you wish to edit and click OK
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· Edit the region and change the default mask file
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You can also create a new mask file if you have a vector map file such as a shapefile or a bna file. Just make sure that the region that you want to be masked is the active region. The vector file should be in geographic projection. 
· On the menu bar, go to File > Import > Vector File to Bil File > Vector to Mask

[image: image18]
· Make sure the Apply Changes to Program check box is checked if you want the new map file to be applied to the active region. However, as long as you take note of where the output bil file is being placed, you can always change the mask file in any region (as described above) at a later stage. 
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You may have maps that you would like to be overlaid on the GeoWRSI display, other than the default map that is provided with the program.  The GeoWRSI provides the facility to add or remove maps of your own choice.  The maps have to be in bna or shapefile format.
To add, remove or change the way a map appears on GeoWRSI display, go to the menu item: Map > Manage Vector Maps. You will get a dialog box like the one shown below. This dialog box allows you to configure the maps to be overlaid on the GeoWRSI display.
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Adding a map:
· Click on the "Add" button at the top-right of the dialog box that appears. A dialog box like to one shown below appears
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· Click the Browse button to select the map to add to the GeoWRSI. Specify the width and colour of the map line (Map Line Colour), then click OK
· You can add as many maps as you want.
Editing the way the maps are displayed
· You can change the order in which the maps are displayed by selecting a map, then using the up and down arrows at the right of the dialog box to change the order in which they are displayed. The map shown at the top of the dialog box wiill be the map that will be displayed at the top in the GeoWRSI map display.
· If you want to change the way the way a map appears on the display such as the line thickness or the colour, click the map in the dialog box, then click the "Edit" button, and change the relevant display settings. When you have finished click OK.
Removing a map:
· To remove a map from the GeoWRSI display, select a map from the dialog box, then click the "Remove" button, then click OK.
· The display will then be drawn minus the map you removed from the map list.
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Menu Path: Setup > SOS Def
The SOS Definition menu command allows you to define the start of season (SOS) that will be used in the crop-water balance modeling or to determine the way in which the start of season will be defined. The SOS is used as the planting date in the GeoWRSI, the dekad in which the crop is modeled to start growing. To select any of the options, click on the menu item (for example, click on "Use Climatic Average" if you want to use the climatological SOS file defined for that region file, or click on "Select SOS Dekad" if you want the SOS to be a specific dekad, such as dekad 31, which is dekad 1 of November, for the entire study area). The menu item that is ticked is the one that will be used by the program during the water balance model run.
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Various options can be used to define the start of season, as described below.
1. Calculate the SOS using the rainfall or soil moisture. There are several ways of calculating the SOS, which are discussed in further detail under the topic Calculating SOS. The menu item for this selection is Setup > SOS Def > Calculated SOS.
2. Select a different existing raster bil file with SOS values (expressed in dekads of the year between 1 and 36). The menu item for this selection is Setup > SOS Def > Select SOS File.
3. Use a single SOS dekad for the entire study area without any variation between pixels. The menu item for this selection is Setup > SOS Def > Select SOS Dekad.
4. Use the climatological SOS defined in the region file as the SOS for that particular year. The menu item for this selection is Setup > SOS Def > Use Climatological SOS.
5. Add or subtract a user-specified number of dekads to or from the SOS at each pixel. This is useful if you want to increment SOS over a period of time and see the variations in water balance given that planting was done at SOS, SOS+1, SOS+2, and so on. The menu item for this selection is Setup > SOS Def > SOS +/-.
6. Use SOS data (administrative boundaries or tabular data that can be linked to a vector file) from a vector file (shapefile). This is useful if you have a field-based crop-monitoring system that provides information on planting dates summarized by administrative boundaries. This then allows you to use actual planting data for your SOS file. Note that when you use this feature, the menu item that will become ticked will be Select SOS file. The technique for this methodology is discussed in further detail under the topic Incorporating field SOS, LGP and WHC data using vector data. The menu item for this selection is Setup > SOS Def > Import SOS from Vector File.
Two other set up menu items are available to help configure the SOS file:
1. Define SOS Calculation Parameters. This allows you to configure the way in which the SOS should be calculated. More information on this option is available under the topic Calculating SOS. The menu item for this selection is Setup > SOS Def > SOS Calculation Parameters.
2. Specify the climatological SOS. This allows you to use a climatological SOS file other than the one specified in the region file. The climatological SOS is used as an option to constrain the current SOS so that it does not start earlier than a certain time relative to the climatological SOS. The menu item for this selection is Setup > SOS Def > Specify Climatological SOS.
More background information is available under the Start of Season topic.
	Calculating Start of Season (SOS)
	




Menu Path: 
1. Setup > SOS Def > Calculated SOS
2. Setup > SOS Def > SOS Calculation Parameters
When you have opted that the water balance model should calculate the SOS (using the menu path Setup > SOS Def > Calculated SOS), various options are available to determine exactly how the SOS should be calculated. These options can be accessed using the menu item Setup > SOS Def > SOS Calculation Parameters.

When you click on this menu item, you get a form that looks like the one below.
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There are a number of options for calculating the SOS.

1. Select Type of SOS Calculation
The first option is on the type of SOS calculation. There are two types of SOS calculations available on the GeoWRSI:
1. 3-Dekad Rain Threshold
2. Soil Moisture Threshold
You can change these options by clicking the arrow under "Select Type of SOS Calculation," then selecting the appropriate button.

The 3-dekad rain threshold is the standard methodology used by the operational GeoWRSI run at the USGS Earth Resources Observation and Science (EROS) Center. This technique, otherwise known as the rainfall-accounting method, developed at the Agriculture-Hydrology-Meteorology (AGRHYMET) Regional Center in Niamey, Niger (AGRHYMET, 1996), involves monitoring rainfall over a running 3-dekad window. If there is at least 25 mm of rainfall in the first of the 3 dekads, and there is at least 20 mm of rainfall summed over the next 2 dekads, then the season is determined to have started. The operational GeoWRSI uses these as the standard rainfall threshold amounts. 

The soil moisture threshold is a more experimental technique and relies on the soil moisture calculated from the water balance modeling. The soil moisture is accumulated from 6 dekads before the season is due to start (as defined by the region file) and is monitored from the time the season starts. When the soil moisture, as a percentage of the water holding capacity, goes above a defined threshold, then the season is deemed to have started in that area.

Differences Between the 3-dekad rain threshold and the soil moisture threshold techniques
From a conceptual point of view, one of the main differences between the two techniques described above is that the 3-dekad rain threshold is retrospective and only fully decides that a start of season occurred at least 2 to 3 dekads after the event. This is mainly to ensure that rains that permit planting should not be followed by a dry spell, which would implicitly imply a false start and failed germination. In contrast, the soil moisture threshold does not have the privilege of hindsight—if there is a dry spell immediately after the start of season, the crop will experience a false start. 

A second difference between the two, from a practical point of view, is that the 3-dekad rain threshold technique has been used and tested and found to reasonably simulate planting behavior in many instances using the coarse, wide-area datasets typically used in the GeoWRSI, whereas the soil moisture threshold technique has not. The soil moisture technique should be used with caution and testing, but it has been included here because of its potential.

2. Defining Minimum Thresholds for the SOS
For both the rain-thresholding and the soil moisture thresholding techniques described above, the user has the option to define the thresholds that should be used. For the rain threshold, two thresholds need to be defined: one for the first dekad (minimum rainfall for dekad 1) and the other for the sum of the next two dekads (minimum rainfall for dekad 2 + dekad 3). When the conditions specified by the user are satisfied, the program considers this as the start of season. For the soil moisture thresholding, only one threshold needs to be defined, which is the minimum soil moisture for defining the start of season. The appearance of the form when the user selects rainfall and when the user selects soil moisture thresholding is shown in the graphic below. The boxes highlighted in red (they will not be in red on the program) are the areas that the user must change to change the thresholds.


[image: image23]

3. Excluding Areas that Will be Incomplete by the Time the Water Balance Model Stops Running
There are some areas where the start of season is calculated so late that by the time the water balance model stops running, the crop will not have finished. These may be spurious and rare pixels, but they do affect the result because the WRSI portrayed at the end of the season will not be realistic. The crop may appear to  have sufficient water based on the WRSI result, but we may in fact be seeing the result at say 40 percent of the crop's phenology. There may be no rainfall after that, so even though the crop appears green, it may eventually be crop failure.

The user has the option to exclude areas from the SOS that will be incomplete by the time the season ends. These areas will then be marked as having "No Start" in the SOS product. This is done by clicking to make sure that there is a tick on the box where it is written, "Exclude areas that will be less than X percent complete by the end of the season.” You can also define the percentage completeness because at some point, the lack of completeness will not make much of a difference (for example, when the crop is 95 percent complete, rainfall patterns thereafter may not make a significant difference to the crop, and it can be harvested then while it is 95 percent complete). 
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To choose to exclude these areas, the user can click in the area highlighted in red, and to change the percentage completeness cutoff, the user can change the number in the box highlighted in green in the graphic shown above.

4. Using SOS Climatology in the Calculation of the SOS
The main purpose of the SOS climatology in the SOS calculation is to constrain the SOS so that the season will not start too early or too late. In most areas, the rainfall season normally starts at about the same time, give or take a few dekads. Farmers get used to this normal start of rains and will generally not plant way before the normal start of rains, even if some off-seasonal early rains occur during any given season. As the SOS calculation is generally trying to mimic planting behavior, and to avoid false starts, it is important to constrain the SOS calculation in some way so that the SOS product will not give abnormally early season-starts, even if early off-seasonal rainfall events occur that satisfy the computational thresholds for start of season. It may also be important to constrain the SOS so that planting does not occur abnormally late.

The way this constraint is done in the GeoWRSI is by specifying that there will be no start of season that occurs a given number of dekads before the normal (or climatological) start of season, Even if the rainfall or soil moisture patterns allow the algorithm to initiate start of season and this happens before the given number of dekads before climatological SOS, then that event will be ignored by the program and an SOS will not be set forth. This number can normally be anything between 0 and 3 (0 meaning that no start of season will occur before the climatological start of season, and 3 meaning that no start of season will occur more than 3 dekads before the climatological SOS). A constraint is also applied in the GeoWRSI to ensure that no SOS occurs a given number of dekads after the climatological start of season. By default, this number has been set to 9

This constraint can be set by changing the number in the highlighted box below, in the text box that is in front of the caption written "Max Dekads Early." In this example, the calculated SOS will not come more than 2 dekads before the climatological SOS. The “Max Dekads Late” constraint will also prevent the SOS from occurring unrealistically late, and in the example shown, this is more than 9 dekads (or 3 months) after the climatological start of season. 
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Ignoring the SOS Climatology
In the graphic above, in the highlighted box, you have an option to "Ignore SOS Climatology." You can activate this option by clicking on "Ignore SOS Climatology". When this box is ticked, the GeoWRSI will calculate SOS the first time that all the conditions and thresholds for start are satisfied, regardless of the SOS climatology.

This option is useful if you have no SOS Climatology or if you want to run several years of SOS to recalculate the SOS Climatology later (in a separate GIS package).

5. Recalculating SOS after Crop Failure
Sometimes crops fail during the rainy season due to poor rainfall performance, and in some areas, farmers can replant soon after crop failure. Because we want to mimic planting patterns, the GeoWRSI also presents this option to the user to allow the program to recalculate SOS after crop failure. The final SOS that you see calculated by the GeoWRSI will then be the recalculated one, and all previous SOS occurrences in an area where there was crop failure will be ignored.

To activate this option, ensure that the option "Recalculate SOS after crop failure" is checked. Click on this option if necessary.. This is as shown in the area highlighted in red in the graphic below.
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Once you have decided that you want to recalculate SOS after crop failure, the next (or first) logical question is how to define crop failure. On the ground, it is straightforward—you can see that the crop has dried up, and you get some seed and replant. In the model, however, we need to decide how best to mimic ground conditions. The model presents two ways we can define crop failure. This is found in the center of the box highlighted above, "Crop Failure Definition for Re-start." The user can define crop failure using a WRSI threshold or a Soil Water Index (SWI) threshold. If the water balance falls below the threshold specified by the user, then that is defined as crop failure, and the GeoWRSI starts searching for another SOS using the same minimum thresholds already specified for SOS calculation in sections 1 and 2 of this topic. Click on the arrow in the highlighted green section below to select either of the two options, then change the text box on the right, next to the % sign, to change the thresholds. A recommended WRSI threshold for defining failure is 30 percent, and a recommended SWI threshold for defining failure is between 1 and 10 percent. The two options are illustrated below, highlighted in green.
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The final consideration in recalculating the SOS is that at some point during the season, it will be pointless to restart the calculation, so you need to set cutoffs so that the program will not try to recalculate SOS late in the season. You can specify this by filling in the number specified where you see the text, "Don't restart after 40% growing period." The "40%" can be changed to suit local behavior. The 40 percent there means that after the crop has grown for 40 percent of its total crop cycle and it fails, then the farmer will not replant (and the program will not recalculate), but before 40 percent of the crop cycle has gone by and there is a crop failure, then the program will recalculate SOS.

References:
AGRHYMET, 1996. Methodologie de suivi des zones a risque. AGRHYMET FLASH, Bulletin de Suivi de la Campagne Agricole au Sahel, Centre Regional AGRHYMET, B.P. 11011, Niamey, Niger, Vol. 2, No. 0/96, 2 pages.

	Using Field-Based Information in the GeoWRSI
	




One of the emphases in developing the GeoWRSI has been the need for making data for running it easily available. So automatic methods for calculating the start of season, default datasets of length of growing period that come with the program, and climatic data such as rainfall and evapotranspiration can easily be downloaded over the Internet and imported into the GeoWRSI for running.

However, one key recognition made has been that users may often have their own data that are better resolution and more accurate than the data that are globally available, or their data can be produced using assumptions made in models. With this in mind, several modules have been incorporated into the program to help users import their own data into the GeoWRSI.

This section introduces how your field-based information such as planting dates, length of growing period, and water holding capacity can be incorporated into the GeoWRSI so that you can use this information to run the water balance model. 

There are two basic methods for changing a parameter. In this explanation, we will use the planting date as an example:
1. If you have a basic "feel" for how the parameter (planting date) is changing over space, you can paint in the values of the planting date over the different parts of the grid.
2. If you have the parameter (planting date information, in this case) recorded by administrative boundary such as district, and you have a shapefile of that administrative boundary, you can import the information into the GeoWRSI directly by using a text file that you attach to the shapefile.

Information on how to import your own local rainfall information into the GeoWRSI is presented in the next section, but for now, we provide more information on the topics already described above.
	Drawing in Field-Based Information from Ancillary Data into the GeoWRSI
	




There are two ways to enter field planting information into the GeoWRSI. This section looks at the first of these two methods. 

1.  Entering the field information from scratch 

It can be digitized online into the GeoWRSI:

· Go to Setup > SOS Def > Use Climatic Average. This will allow you to have a template onto which to digitize.
· Overlay your vector map file (in bna format) of interest. This is done on the menu item using Map > Add Map or Map > Remove Map. It is recommended you use the bna map file with the same administrative boundaries as those for which you collected the field information.
· Click the SOS tab so that you are viewing the SOS map.
· Start editing the SOS map by clicking on the menu item Image > Start Editing. You will be given a dialog box to enter the value you wish to digitize. This value is the dekad that you wish to digitize on the map, so if you wish to digitize the areas where planting was in March dekad 2, for example, the value you would type in the dialog box would be 8. Click OK.
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· Next, you will be prompted to enter the width of the brush you want to use (in pixels) between 1 and 10. Use a wider brush (closer to 10) to paint large areas at one go, and use a thinner brush (closer to 1) for painting fine lines that may be closer to your boundary for that particular planting dekad.
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· Click and drag to paint over the area of interest.
· When you have finished painting your area of interest for that particular planting dekad, move on to the next planting dekad by going to the menu item Image > Change Edit Value. You then have to again enter the new planting dekad value you wish to digitize and the width of the painting brush to use.
· When you have finished digitizing, go to Image > Stop Editing Image and click Yes when asked whether to save changes to File. Type a unique filename for the new file in the directory you are saving to when you are prompted to “Save File As” and click “Open” to save. Be sure to include the .bil extension in the filename because the program does not add it for you. Click Yes when you are asked whether to apply the changes to the program. 
NOTE: When digitizing planting date information, the value “60” represents No Start, while the number “0” represents missing data, or “N/A”. For all other values, use the value of the dekad of planting between 1 and 36.

	Incorporating Field Based Information into the GeoWRSI using Administrative Boundaries
	




There are two ways to enter field planting information into the GeoWRSI. This section looks at the second of these two methods.

If your field information such as planting dates or LGP has been collated by administrative units such as districts or provinces, you can enter this information into shapefile tables and enter this into the GeoWRSI. If you do not have a shapefile table editor such as ArcView, you can also enter this information into a table that you can then link to GeoWRSI.
Either 
1. Enter the field information into shapefiles in ArcView or other GIS package. The shapefiles should be in geographic projection.
2. Import the shapefiles into the GeoWRSI using the menu item File > Import > Vector File to Bil Image > Vector to SOS. You can also choose Vector to LGP or Vector to WHC instead if you want to import either of these parameters from field information.

Or

1. Use the menu item Tools > View Map Table to open the data table of the shapefile or bna for the administrative units that you want to work with. For this example, specify C:\GeoWRSI\Samples\Maps\mw_rdp.shp.
2. Click on Export to CSV and save as an appropriate filename. For this example, we will save to c:\GeoWRSI\Samples\Output\mw_rdpsos.csv.
3. In Windows Explorer, go to the csv file you have just saved and double-click it to open it.
4. Add a new column to the csv file and call it SOS (or if it is LGP, you can call it eg LGP). You can delete the NumVertices column if you like.
5. Fill out the SOS column with the appropriate values, then save and close. Make sure you close the file after you have finished editing it.
NOTE: For SOS field data, the value “60” represents No Start, while the number “0” represents missing data, or “N/A”. For all other values, use the value of the dekad of planting between 1 and 36.
6. In the GeoWRSI, use the menu item File > Import > Vector File to Bil Image > Vector to SOS. Select the "Join Vector File to a Secondary Data Table" option.
7. Fill out the table as appropriate. You can change the outputname from the default to a more appropriate name by clicking on the browse button. An example is shown below for a filled-out form. Once you have filled out the form, click OK. 
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You can click the SOS tab to see what the new SOS looks like.

You can do the same process with LGP, using the menu item File > Import > Vector File to Bil Image > Vector to LGP.
	Running the Model for Other Crops
	




Other crops in the GeoWRSI
The GeoWRSI comes with only eight different crops installed: cassava, cotton, maize, millet, range, rice, sorghum, and wheat. 

Maize (corn) is the default crop, but other crops can also be activated by going to the menu and clicking Setup > Crop Type and then selecting the crop of choice.

Activating other crops
If the crop you wish to model is not among the list of predefined crops mentioned above, you can add your own crops. To do this, click on the menu File > New > Crop. You will then be presented with a dialog box which will allow you to define the name of the new crop and to specify the parameters of the new crop. 

If the new crop you want to model is only slightly different from one of the existing crops, you can also use the menu File > Edit Crop, then save the crop file with a new crop name.

For more information on these crops, you can view the help topic on Defining  GeoWRSI Crop Parameters.  

 

	Defining GeoWRSI Crop Parameters
	




This section explains the GeoWRSI crop parameters that are used as inputs to the model. You can change these parameters to create new crops that the GeoWRSI can run, but this should be done with sufficient theoretical and agronomic background.

When you click on the menu items File > Edit > Crop and you select a crop to edit, or when you select File > New > Crop, you get a form with a number of text boxes that you have to fill out. The form looks something like the one below.
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This form contains parameters that describe the characteristics of the crop in a way that allows it to be modeled by the GeoWRSI.

An annual crop's growth cycle, between the time it was planted to the time of drying, was divided by FAO into four different growth stages:
· Initial Stage 

· Vegetative stage 

· Flowering stage 

· Ripening stage

At each of these stages, the crop's water requirements differ somewhat when compared to the evapotranspiration of a reference crop under given meteorological conditions. Empirical studies have allowed the development of relationships between the water requirements of a reference crop, which can be modeled using various methods such as the Penmann-Monteith method, and the water requirement of the crop at its various stages. Generally, the water requirement of a crop at its stage can be calculated by multiplying the reference crop's water requirement by a coefficient. 

The GeoWRSI requires information for each crop on the period during the crop's cycle when it transitions between one crop stage and another, as well as the coefficient by which to multiply the reference crop's water requirement at the critical turning points in the crop's growth cycle. In defining these parameters, the entire growing period is defined as 1, and the various stages of phenology are described as fractions of the complete growth cycle, between 0 and 1. Therefore, a phenology of 0 is the start of the crop's growth cycle, and a phenology of 1 is the end of the crop's growth cycle.
Some notes about the crop parameters:

1. Fraction at Start of Vegetative Stage (F1)
 The fraction of the crop's growth cycle at which it changes from the initial stage to the vegetative stage. For the default maize crop shown above, this fraction is set at 0.16. In other words, when the maize crop shown above is at 16 percent of its growth cycle, it transitions from the initial stage to the vegetative stage.

 2. Fraction at Start of Flowering Stage (F2)
 The fraction of the crop's growth cycle at which it changes from the vegetative stage to the flowering stage. For the default maize crop shown above, this fraction is set at 0.44. In other words, when the maize crop shown above is at 44 percent of its growth cycle, it transitions from the vegetative stage to the flowering stage.

3. Fraction at Start of Ripening Stage (F3)
 The fraction of the crop's growth cycle at which it changes from the flowering stage to the ripening stage. For the default maize crop shown above, this fraction is set at 0.76. In other words, when the maize crop shown above is at 76 percent of its growth cycle, it transitions from the flowering stage to the ripening stage.

4. Crop Coefficient at Initial Stage (kc_ini)
The crop coefficient by which reference crop evapotranspiration is multiplied to calculate the crop's water requirement during the initial stage.

5. Crop Coefficient at Flowering Stage (kc_mid)
The crop coefficient by which reference crop evapotranspiration is multiplied to calculate the crop's water requirement during the flowering stage.

6. Crop Coefficient at end of Ripening Stage (kc_end)
The crop coefficient by which reference crop evapotranspiration is multiplied to calculate the crop's water requirement at the end of the ripening stage.

7. Maximum Root Zone for the Crop
This is an estimate of the effective maximum depth for a given crop. This helps to calculate the root growth function from the initial to the maximum. 

8. Initial Root Depth 
Modeling of root growth is handled using a simple linear function from the initial root depth to a maximum that is reached during the reproductive/flowering stage. 

9. Maximum Allowable Depletion of Soil (p)
This parameter varies by crop but is generally around 0.5. Actual ET will be less than potential ET once the water level goes below this value. 

10. Coefficients for calculating actual ET (crop_c1 and crop_c2)
These coefficients are used to improve the shortcomings of a 10-day water balance in the calculation of ET. A daily water balance model would not require them. These parameters are obtained by trial and error, and ETa calculation is not very sensitive to them. 

For more detailed information, read the FAO Irrigation and Drainage Paper 56 (http://www.fao.org/docrep/X0490E/X0490E00.htm).

	Running the Model for Other Regions
	




Default GeoWRSI Regions

A GeoWRSI region is a set of parameters that define the location and season for which a water balance model run can be performed. It is fully defined under the topic GeoWRSI regions explained.

Six default regions come with the GeoWRSI installation:

· Central America 

· East Africa (March–September season) 

· East Africa (May–November season) 

· East Africa (October–February season) 

· Southern Africa 

· West Sahel Africa

You can set the model to run for any of these regions using the menu item Setup > Region then selecting the region. You can also set up a new region with different region parameters using the process outlined below.

Setting up a new region in the GeoWRSI

A region can be defined in the GeoWRSI using the menu bar. You can either create a new region or edit an existing region and then save it as another region. To access these commands, you can use File > New > Region and File > Edit > Region on the menu bar, respectively. It is a greater advantage to edit an existing region and save it as a new one if the new region shares several parameters with the existing region. For example, it may share the same rainfall and evapotranspiration data or the same WHC. 

If you have a region file already created on another computer or at a different time, you can import that region into the GeoWRSI using the menu command File > Import > Region. You will probably have to change the paths specified for specific files and directories (as specified below) so that they are correct paths on your computer (unless the directory path/structures are the same as the files on which the region files were created).

When you click File > Edit > Region on the menu bar to create a new region by editing an existing one, you will get a screen that will allow you to choose the most appropriate region to edit. After you have selected that region and clicked ok, you will get a screen that allows you to edit the region as follows:
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Edit all the parameters as appropriate but make sure you click the "Save As" button when you are finished, not the save button. 

If you click File > New > Region on the menu bar to create a new region from scratch, you will get the same screen as above, but all the fields will be blank (except the pixel height and width, in which values of 0.1 are suggested, but you can change them if necessary). In addition, the "Name of Region" field will be editable so that you can type in the name of the new region (which you cannot do when you edit the region, but when you choose "Save As," the filename you save is the name that the region will adopt). 

	GeoWRSI Regions Explained
	




What is a region
A region, in the GeoWRSI context, is a set of parameters that define the location and general characteristics of an area for which water balance modeling is to be performed. These parameters are specified in the region file and include the following:

· The geographical extent of the region 

· The pixel size of the outputs from the water balance run (usually 0.1 degrees) 

· The approximate start and end of the season (the actual water balance run is not constrained to these values, but they are in fact used as a general guideline) 

· The climatological start of season (SOS) 

· The climatological WRSI 

· The length of the growing period (LGP) 

· The water holding capacity (WHC) 

· The mask for masking out areas that are not of interest 

· The lookup palette (color table) for the start of season 

· The data directory with the precipitation and evapotranspiration files 

· The associated vector file (shapefile or BNA). 

In the GeoWRSI, you can run a water balance model for any place on Earth for which you can specify these parameters. The climatological SOS, climatological WRSI, the LGP, the WHC, and the Mask need to be bil files, and you must specify to the GeoWRSI what is the full path of these files. Although these files that are specified in this entry form above are used as defaults in the water balance calculation, it is possible to use other files in the calculation, and these can be specified in the Setup menu item. The color table for the SOS is a Windisp-style file (http://www.fao.org/giews/english/windisp/windisp.htm), and the vector file can be a shapefile or BNA file that will be used as an overlay in the display of the water balance outputs to provide context to the results. The data directory contains precipitation and evapotranspiration files as subdirectories, and the path of this directory also has to be specified. 

For your region to run, all the bil files specified in your region file need to be at least equal in size to, or bigger than, the geographical extent defined in the region file. If this is not the case, you will get an error: "Image is smaller than analysis area. Cannot load it up." And the analysis will not run.

All bil files (Clim SOS, Clim WRSI, LGP, WHC, mask) must be in geographic (lat/long) projection.

A region can be defined using the File > New > Region and File > Edit > Region menu items. You will get a dialog box that looks like the one shown below.
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Some notes about the region parameters:

1. The Geographical Extent of the Region
 The geographical extent of the region is defined by the minimum longitude, maximum longitude, minimum latitude, and maximum latitude. You can either type in these parameters or click the "Get extent from map" button, select the map you wish to use to define the extent, then zoom in to the areal extent that you want to define as your map area, and close. The minimum longitude, maximum longitude, minimum latitude, and maximum latitude will automatically be defined for you in the appropriate text boxes.

 2. The pixel size of the outputs from the water balance run
 This is defined as the "height of pixel" and "width of pixel" in the entry form above. This is the pixel size of the outputs from the model and is in degrees. A default size of 0.1 degrees is probably sufficient for most analysis to which the GeoWRSI is subjected, but for studying smaller areas, it may be useful to use a smaller pixel size such as 0.05 degrees or smaller. However, it is not very useful to make your pixel size extremely small because this will only lengthen the time of computation, and it does not give any better output than the finest (resolution) of your inputs (for example, if your finest inputs have a pixel size of 0.5 degrees, the practical resolution will not be better than 0.5, even if you specified a size of 0.1 in this input). The GeoWRSI can take inputs from grids of various sizes, so this should not be a deciding factor. In general, we advise that you make this parameter equal to the pixel size of your rainfall grids if this is less than 0.1 degrees, because rainfall is in many cases the most influential determinant of the water balance.

3. The approximate start and end of the season 
This is defined in the entry form above as the "Initial Dekad of Season" and the "Final Dekad of Season." These are the approximate times that the model starts and ends. In fact, the model starts searching for the start of season only after the "Initial Dekad of the season," and for each pixel, it will run from the actual start of the season (which can be defined in various ways) and will continue until the LGP has been completed. For example, suppose the Initial Dekad of the Season is 25, and the Final Dekad of Season is 15 (of the following year). We take an example of pixel X. Suppose there is enough rainfall in pixel X by dekad 21 to satisfy an SOS. But an SOS will not be registered in dekad 21 because that is before the Initial Dekad of Season. Suppose that there was again enough rainfall in dekad 36 and an SOS was registered in dekad 36. Suppose pixel X had an LGP of 18 dekads. So pixel X will do a water balance from dekad 36 for the next 18 dekads until it finishes at dekad 17 of the following year. Note that pixel X ran even past the Final Dekad of the Season. That can happen because the main criterion is that the LGP should finish. The only exception to this is that the GeoWRSI cannot run a water balance analysis for more than 35 dekads, so if the time that the crop's run will cause it to go for 35 dekads beyond the initial dekad, then the growth of the crop will be cut off before the end of the cycle. Thus, the actual water balance run is not constrained to the approximate start and end of season as defined in the entry form above, but these values are used as a general guideline.

4. The climatological start of season (SOS)
This bil file is the climatological (average or median) start of season. If you do not have one, but if you have all the input rainfall data, you can actually calculate it by running SOS analysis for several years through a batch process in the GeoWRSI and then calculating an average or median. This file is particularly used for constraining the SOS calculation so that it does not start earlier than X dekads before the climatological SOS and for calculating the SOS anomaly. However, you have the option in the GeoWRSI of switching off the climatological SOS constraint so that current-season SOS is not constrained to start within a certain range from the climatological SOS. Therefore, if you do not need to set the SOS climatological constraint, and if you do not need to calculate the SOS anomaly, then you can set a dummy file for the climatological SOS.

5. The climatological WRSI
This bil file is the climatological (average or median) WRSI. If you do not have one, but if you have all the input rainfall data and other required parameters, you can actually calculate it by running WRSI analysis for several years through a batch process in the GeoWRSI and then calculating an average or median. This file is particularly used for calculating the WRSI anomaly. Therefore, if you do not need to calculate the WRSI anomaly, then you can set a dummy file for the climatological WRSI. You will need to use a dummy to do the multiple runs for the WRSI when calculating a climatological WRSI.

6. The length of the growing period (LGP)
This bil file specifies the default LGP for the area. The values in the bil file need to be in dekads. For example, a value of 9 means 9 dekads (approximately = 90 days).

7. The water holding capacity (WHC)
This bil file specifies the soil water holding capacity, measured in mm/m.

8. The mask for masking out areas that are not of interest
The mask file is a raster bil file that has a value of 1 in areas that should be shown on the map and a value of 0 in areas that have should be masked out. Only pixels with a value of 1 will be displayed through the mask—all other values will be masked out. The mask only applies to raster data; vector data will show through the mask.

9. The lookup palette (color table) for the start of season
This entry is labeled on the entry form above as "Default SOS Colour file." This text file allows the GeoWRSI to look up the values at start of season in the SOS map and then map them appropriately. It is a Windisp-style clr file (http://www.fao.org/giews/english/windisp/windisp.htm). More details on this format can be obtained at http://www.fao.org/giews/english/windisp/manuals/FRAME.htm. The SOS color file for southern Africa is shown below.

From    To    Red    Green    Blue    Files
22    25    163    0    194    <= Sep 1
26    26    191    79    224    Sep 2
27    27    227    173    245    Sep 3
28    28    0    148    173    Oct 1
29    29    33    214    255    Oct 2
30    30    140    242    255    Oct 3
31    31    0    189    46    Nov 1
32    32    61    255    150    Nov 2
33    33    163    255    204    Nov 3
34    34    240    117    0    Dec 1
35    35    255    145    38    Dec 2
36    36    255    184    171    Dec 3
1    1    247    232    204    Jan 1
2    2    230    204    150    Jan 2
3    3    207    168    54    Jan 3
4    21    150    99    0    >= Feb 1
0    0    255    255    255    N/A
60    60    255    247    125    No Start

10. The data directory with the precipitation and evapotranspiration files
This is labeled in the form above as the "Data directory (with PPT and PET)." It contains dekadal annual and average precipitation and evapotranspiration data. These data need to be dekadal. This directory needs to have a very specific structure. Inside the directory specified there should be at least two subdirectories called PPT (precipitation) and PET (evapotranspiration). These two subdirectories should have PPT and PET data. There should be at least 36 long-term average PPT files and at least 36 long-term average PET files. The average PPT files should have the file naming convention:
ppt01.bil
ppt02.bil
ppt03.bil
ppt04.bil
...
ppt35.bil
ppt36.bil

And the average PET files should have the file naming convention:
pet01.bil
pet02.bil
pet03.bil
pet04.bil
pet05.bil
...
pet35.bil
pet36.bil

The annual PPT files should have the file naming convention pptYYYYDD.bil, where 

 YYYY  is the year and
 DD is the dekad between 01 and 36. 
The prefix "ppt" should be on all the files.

The annual PET files should have the file naming convention petYYYYDD.bil, where 

 YYYY  is the year and
 DD is the dekad between 01 and 36. 
 The prefix "pet" should be on all the files.

The files for 2005 for PPT would be
ppt200501.bil
ppt200502.bil
ppt200503.bil
ppt200504.bil
...
ppt200535.bil
ppt200536.bil

And the PET files for 1997, the associated vector file (shapefile or BNA), would be
pet199701.bil
pet199702.bil
pet199703.bil
pet199704.bil
pet199705.bil
...
pet199735.bil
pet199736.bil

If your region is not in Central America or Africa, you will have to find a way of creating the averages and naming them correctly. However, there are ways of importing the annual data—look in the File >Import menu tools.

11. The associated vector file (shapefile or BNA)
Labeled as the "default map file" in the entry form above, this file is mainly for display purposes. This vector file can be in shapefile or BNA format and is used as an overlay in the display of the water balance outputs to provide context to the results.
 

	Resetting the Default Regions
	




If you have changed the default region file, you may want to, at some stage, reset the region files to their original settings. There are two ways of achieving this.

Option 1
Reset all the default files using the Tools > Restore Default Program Settings command on the menu bar. You can also use the Start Menu on your desktop by clicking the command sequence Start > All Programs > GeoWRSI > Tools > Fix GeoWRSI Settings. If you choose to use this option, make sure the GeoWRSI program is closed. This command will reset all the main program settings back to their default values, so if you want to keep your other settings, do not use this command.

Option 2
A more involved procedure can be used to allow you to reset only the region files. This can be done using the link to the GeoWRSI data and settings directory. The procedure for re-initializing the region files using this method is as follows:

a) Ensure that your current region is set to one of the default regions that come with the program. Close the GeoWRSI program if it is running.
b) On the start menu, click the command sequence Start Menu > All Programs > GeoWRSI > Tools > GeoWRSI Data and Settings. 
c) Open the "regions" folder and delete all the region files in that folder.
d) Open the GeoWRSI program to automatically re-create all the default region files.

e) This is a rather involved sequence. It's easy to make a mistake, so if the program stops working after this, use the Fix GeoWRSI Settings as described under Option 1 above.
	Validating Rainfall Estimates
	




The next topic addresses the issue of improving rainfall estimates, but before getting there, a good precursor to that topic is to address the question of how we can tell how good or how bad are the rainfall estimates that we are using in the GeoWRSI.

The GeoWRSI allows validation of rainfall estimates on a dekadal basis for those places where station data are available. The basic procedure is as follows:

1. Extract the rainfall estimate values at those locations where the station data exist.
2. Interpolate the station data to produce interpolated values at those locations where the station data are located.
3. Do a regression (a) between the raw station values and the co-located RFE values and (b) between the interpolated station values and the co-located RFE values.

The RFE validation outputs are as follows:
1. Present the user with a series of statistics including the correlation coefficient and the slope of the regression (for the correlation between the station values and the RFE values).
2. Present the user with a scatterplot of the station values versus the co-located RFE grid values.
3. Present the user with a map of the RFE overlaid with a map of the station data using the same legend.
4. Create a shapefile of the station locations with attributes being the rain gage value and the RFE value at the location of the station.

The validation can be done either for a single rainfall estimate or for a series of rainfall estimates, which may cover several years. 

Validating 1 rainfall estimate
Validating several rainfall estimates

The following exercises can be done using the sample data that can be found in C:\GeoWRSI\Samples if you have installed the samples folder that can be downloaded from the GeoWRSI ftp site.

Validating one rainfall estimate
To validate a single rainfall estimate, use the menu sequence Tools > Validate Rainfall Estimates. This will activate a dialog box that will allow you to specify the rainfall estimate file, the station file, and the file where the outputs will be placed.

The inputs for validating one RFE need to be in the following format:
- The rainfall estimate must be an ArcView bil file in geographic projection
- The station data must be in a csv file (a text file in which the values are separated by commas) in the format: Station Name, Longitude, Latitude, Station Value

The specifications for the RFE validation in the example should be as follows:

Rainfall Station File: C:\GeoWRSI\Samples\ire\stations\raingauge2008033.csv
Rainfall Estimate Raster File: C:\GeoWRSI\Samples\ire\grids\ppt200809.bil
Missing value range: From –9999 To –999
Output File: C:\GeoWRSI\Samples\ire\output\validate08033.csv

Note: the output file can be any filename that you specify, but for the purpose of this exercise, we suggest the name given above.

When you have entered all the required inputs, the screen file should look like the one below.


[image: image34]

Click OK to start the validation process. You will then get a map that shows the RFE overlaid with the station values as shown below.


[image: image35]

When you close this map window, you will get three other outputs: two of them are text files opened in Notepad, and the third is a graph showing a scatterplot of the interpolated rainfall station values and the RFE values. The text files have the same information: 
(1) a list containing station name, longitude, latitude, rain gage value, interpolated rain gage value, and RFE value 
(2) summary statistics summarizing the relationship between the RFE and the rain gage data.
The text file can be opened in Excel (by default, it's a csv file) for better viewing of the columns

You can validate several rainfall estimates in this manner because the "Validate RFE" form remains open even after the results are posted. Click Close when you have finished.

The top and the bottom of the text file as seen in Notepad are shown below.

[image: image36]

And the scatterplot is shown below.

[image: image37]

All outputs are placed in the same directory where you specified that the "output file" should go (from the first dialog box you filled in during this section).


Validating several rainfall estimates

You can repeatedly validate several rainfall estimates using the procedure described above, because the "Validate RFE" form remains open even after the results are posted. However, it will be quicker to use the Batch Processing Facility, either writing your own code or using the Batch Processing Assistant to write the code for you. In this example, we will use the Batch Processing Assistant to validate the rainfall estimates from dekad 1 of January to dekad 3 of June 2008.

Required Data Formats:
The inputs for validating one RFE need to be in the following format:
- The rainfall estimate must be an ArcView bil file in geographic projection.
- The station data can be either all in one file or in several different files (one file for each dekad) in a single folder.
If the station data are going to be all in one file, it must be arranged in columns with a delimiter such as a comma or a semicolon separating the columns. The following columns must be present:
Station Name, Longitude, Latitude, Dekad1_Data, Dekad2_Data, Dekad3_Data, Dekad4_Data, ... Dekad36_Data, and Year.
 If the station data are going to be in different files, one file per dekad, each file must be named in a consistent fashion in which the date of the file can be derived from just the filename using one of the Date Formats that can be recognized by the GeoWRSI, and each file must be in a csv format (a text file in which the values are separated by commas) in the format: Station Name, Longitude, Latitude, Station Value.


Use the menu sequence Tools > Batch Processing Assistant to activate the Batch Processing Assistant. Select the "Validate RFE" option and press next.



In the next screen, specify that you want to validate RFE from dekad 1 of January 2008 to dekad 3 of June 2008, then click next.
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You will then be presented with a screen that allows you to specify the folder containing the rainfall estimates (grids) that you want to validate, the file naming convention of the rainfall estimates, the station or folder containing the rainfall station data that you are going to use to validate the rainfall estimates as well as the format of that data, and the output file that is going to contain the statistics for all the validations that are done. Other output files will be produced as described in the previous section, and these will all be placed in the same folder that will contain the output statistics.

For this example, fill in the following specifications:

For the Grid Section:
Missing value FROM –9999 TO –999
Folder containing Grids: C:\GeoWRSI\Samples\ire\grids
Prefix: ppt
Date format: 4-digit year; 2-digit dekad (01–36)
Suffix: .bil

For the Stations:
Specify that "The station data is all in one file" by clicking on the check box to the left of that statement so that it appears ticked
Missing Value: –9999
File with all station data: C:\GeoWRSI\Samples\ire\stations\KMDgauge08h1.csv

Your screen will now look like this:
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As soon as you have selected the "file with all station data," a screen will appear that will ask you to select the row with header, select first data row, and select delimiter. These specifications allow the program to read the station file correctly and to identify the column names, which you will subsequently use to tell the GeoWRSI what each column represents. Fill in this screen as follows:

Select Row with Header: 1
Select First Data Row: 2
Select Delimiter: Comma (,)

You will notice that with each setting you change, the depiction of the data file will change. After all the specifications have been made, the screen should look like this:


[image: image40]

Click OK to return to the Batch Assistant.

You can now specify the different columns (such as column with station ID or column with year). To select a column, for example "Column with Station ID,” simply click on that particular text (click on the text "Column with Station ID") or on the blank box to the right of that text, and a list will appear prompting you to specify the name of the column. When you select the column, the equivalent number representing that column will appear in the blank box.

For this exercise, select the following column names to identify the requested columns (in another rain gage file, the column names may be different depending on the names given to the columns in the header row):

Column with Station ID: STATION
Column with Latitude: LAT
Column with Longitude: LON
Column with Year Info: Year
Column with Dekad 1 Data: Dek1
Column with Dekad 36 Data: Dek36

Then finally, specify the "Stats file tor all outputs" to be C:\GeoWRSI\Samples\ire\output\valdn_08011to063.csv, or whatever path you will save it to. Your screen should look something like the one below.
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Click Finish, and the Batch Assistant will create the code for you, put it in a batch file, and exit. The batch file will look like the one below.


[image: image42]

Although you do no have to, it's good practice to save a new batch file before running it, using the menu sequence File > Save As in the batch text editor. This will allow you to open the same batch file later, change a few parameters if you want to, and produce an entirely different set of results if you need to, with minimal effort. Save the batch file preferably in the folder C:\GeoWRSI\Samples\ire\batch and give it an appropriate name. 

Once you have saved (or not) the batch file, run it either by pressing F5, or by using the menu sequence Run > Run Batch File.

The processing console will provide information on the progress of the validation procedure and give a message to say "Done" at the end of the validation. A comparison lumping all the dekads together is given on the screen, both in the form of a scatterplot and as a listing of all the station data and collocated RFE data, together with the summary statistics such as the correlation coefficient.

This information is immediately presented to the user as shown below.

[image: image43]

In addition to the overall summary statistics, the following outputs are produced for each dekad and put in the same directory where the "Stats file for all outputs" was indicated to go.

1. A csv text file containing a series of statistics including the correlation coefficient and the slope of the regression (for the correlation between the station values and the RFE values)
2. A scatterplot of the station values versus the co-located RFE grid values
3. A map of the RFE overlaid with a map of the station data using the same legend
4. A shapefile of the station locations with attributes being the rain gage value and the RFE value at the location of the station




	Chapter 7. Improving Rainfall Estimates
	




If you have rainfall station data and a correlated grid, such as a rainfall estimate for the same grid, you can produce an improved rainfall estimate (IRE) by combining these two datasets in the GeoWRSI. There are several advantages to this approach:
· Incorporating the spatial variability inherent in rainfall estimates 

· Incorporating the accuracy derived from rain gage data 

· Calculating the accuracy of the original rainfall estimates 

· Getting a measure of the correlation between the original rainfall estimates and the rain gage data 

· Assessing the improvement gained by combining the two datasets 

The mechanics of the IRE process as it is implemented in the GeoWRSI are explained in the topic "Creating Improved Rainfall Estimates using a modified IDW Interpolation Technique."

There are three different ways of accessing the IRE algorithm. 

Improve a rainfall estimate for one dekad at a time
Improve rainfall estimates for multiple dekads using the Batch Processing Assistant
Unbiasing Rainfall EstimatesImprove rainfall estimates for multiple dekads using the Batch Processing Text Editor

If you have no rainfall station data, the simplest way of improving a rainfall estimate is by unbiasing the rainfall estimates. This is explained in further detail under the topic .

Acknowledgements: The IRE concept is based on the Satellite Enhanced Data Interpolation (SEDI) methodology developed by Peter Hoefsloot.

	Creating Improved Rainfall Estimates Using a Modified IDW Interpolation Technique
	





The IRE algorithm is a methodology that was designed for combining rain gage data with satellite-based rainfall estimates to produce a more accurate gridded dataset of rainfall estimates. It has been implemented within the GeoWRSI program to allow for the generation of enhanced accuracy rainfall grids that can be used in soil water balance modeling, as well as for other purposes. Generically, the algorithm combines spatially discrete point data with spatially continuous grid data by interpolating ratios between the point and the grid where these two data are collocated, then multiplying the ratio by the grid. The technique is similar in principle to the SEDI technique that was originated for the Southern African Development Community (SADC)/FAO Regional Remote Sensing Project and developed by Peter Hoefsloot. The interpolation technique is done using the Inverse Distance Weighting (IDW) approach but borrows some concepts from the kriging approach, particularly the use of the concepts of simple and ordinary kriging. The equivalent concepts of “simple” and “ordinary” IDW are explained at a later stage.

The basic concept is the use of two datasets: (1) a point dataset with values at discrete points in space (for example, rain gages) and (2) a grid dataset with values varying continuously over space (for example, a satellite-based rainfall estimate grid or a climatic average). For the algorithm to be used effectively, the two datasets need to be correlated. The first step in the algorithm is to extract values from the grid at all locations where the point data have valid values (missing values can be specified by the user). This produces a comparable dataset of grid values that can be directly compared to the point values. As one option, the user can instruct the program to carry out a least squares regression between the collocated point and extracted grid values and output the R-squared value in a statistical diagnostic file. This allows the user to determine whether the relationship between the grid and the point dataset is worth using to interpolate the data.

MaxRatio
When the values for the grid at the point locations have been extracted, the ratio between the grid and the point value at each point location are calculated to produce a dataset of station/grid ratios. One of the options in the program at this point is that user can specify that the station/grid ratios should be capped to avoid “run-away” values during the interpolation and grid multiplication, which follows after the ratio calculation. For example, assume that rain gage data were being interpolated with a rainfall estimate grid. At a specific point, assume that the point value recorded for the station was 10 mm, while the gridded rainfall estimate had a value of 1 mm. Although the absolute difference between the two estimates is only 9 mm, the station/grid ratio is 10, or 1,000 percent. This ratio will be interpolated, then multiplied by original grid. Assume that 50 km away from that point, the grid had a value of 30 mm. This 30 mm will be multiplied by a value close to 10, depending on the surrounding ratios in the interpolation, and the resultant value may be close to 300 mm. This error can be limited by capping the ratio and instructing the program not to cut off any ratios greater than a certain value. A cut-off ratio of 3 is used by default in the algorithm, meaning that any ratio greater than 3 is reset to 3 (in the example above, the ratio would be 3 instead of 10). However, this ratio can be set to any value by the user (a very large cut-off can be used, for example, 100,000) if the user does not want to have the ratios capped. This maximum, or cut-off, ratio is referred to in the IRE as the MaxRatio.

Search Radius, and Minimum and Maximum Stations
These ratios are interpolated to produce a continuous raster dataset of station/grid ratios that, by default, has the same dimensions as the original grid with which the analysis is being done. Optionally, the user can specify latitude/longitude coordinates that define the spatial extent of the output grid, either directly or using a vector file such as a shapefile to define the extent. The interpolation needs to specify how many points should be used in the interpolation; both the minimum and maximum number of points should be used in the interpolation, as well as the maximum search radius within which to search for points, at any given location. At every location where a value is to be produced, the algorithm will search for the nearest stations that it can find within the allowable search radius from that location and use these in the interpolation. For example, assume that the user specifies that between 3 (minimum) and 10 (maximum) points are to be used within a radius of 200 km. The algorithm will search for the nearest 10 stations within a radius of 200 km. If fewer than 10 stations are found, for example 7, then those 7 stations will be used. However, if the number of stations found is less than the minimum allowable specified by the user, then that location will have a missing value.

Power of Weight
The interpolation also needs to specify the power to which the inverted distance should be raised in calculating the weight of interpolation. By default, a power of 2 is used, though this can be changed by the user.

Fuzzy Distance
In order not to reproduce exact point values, the algorithm has an option to specify a “fuzzy distance.” The fuzzy distance reduces the weight to a point or station that falls within the pixel that is being interpolated. This allows surrounding points to have a (slightly) relatively larger influence than they would ordinarily have if there was no fuzzy distance. The fuzzy distance in the algorithm is specified in units of pixels, and a fuzzy distance of 1 means that the algorithm assumes that the station is 1 pixel-distance away from its actual location, in no particular direction.

Simple and Ordinary IDW
The interpolation can be done in two different ways. There is the option of using either an “ordinary IDW” or a “simple IDW.” An ordinary IDW, similar to ordinary kriging, is the normal method of IDW interpolation, in which no initial weights are assigned to the interpolation. Because of this, as the interpolation is done further and further away from any point locations, the interpolated value will end up looking more like the nearest point values because all the weights are decreasing at the same rate. With the simple IDW, some a priori weights are assigned to every location associated with an a priori value. This can be a given value (for example, 1), or it can be the average of all point values in the grid. The difference is that, as the interpolation moves increasingly further from any point locations, the interpolated value will end up looking more like the a priori value. In this algorithm, the user can specify whether the a priori value will be the global average of all the point values (as in simple kriging) or a predefined value. When interpolating ratios for the purpose of multiplying these ratios by a known grid (as in this case), a good a priori value is 1. This will force the output to more closely resemble the input grid in areas that are further away from any known stations. In the IRE algorithm, this a priori value is referred to as the “forced long range value.” 

Maximum Effective Distance and the Forced Long Range Value
One parameter of the interpolation that is closely related to the a priori value is the “maximum effective distance” (MED). The MED works in the simple IDW algorithm and is the distance that is assigned to the a priori value in the interpolation. The a priori value is analogous to an invisible point that is always present everywhere in geographic space covered by the interpolation. It is always a distance (the MED) away from any point and always has a weight equal to the "Forced Long Range Value." Since IDW assigns interpolation weights based on distance, when all the value points (stations) are further away from the interpolation than the maximum effective distance, the a priori value will have the largest influence on the interpolation at that point. 

Determining the MED is not a straightforward task. Some approaches have been suggested that include analyzing a variogram, calculating the average nearest distance between all the points (stations) in the dataset, and just using an arbitrary distance. The IRE module within the GeoWRSI contains utilities for plotting a variogram and for calculating the average nearest distance between the points, which can both be used for estimating the MED. At the time of writing, only preliminary tests have been done on the effectiveness of using these different approaches, and no conclusive results have yet been obtained. This currently stands as an open research question. 

One simple application of the parameters described above allows the user to incorporate the effect of the surrounding stations within a given radius and, after that, to reproduce the background grid exactly. If the minimum stations are set to 0, and the forced long range value is set to 1, the algorithm will exactly reproduce the original grid at any location where the distance to the nearest station is greater than the maximum search radius.

The algorithm outputs statistics that provide information on the performance of the interpolation. This is provided as an option, and the user can specify whether these statistics should be generated. Three sets of statistics are output:
1.    Correlation between the point data and the original grid data at the collocated points
2.    Cross-validated correlation of the interpolated data 
3.    Cross-validated correlation of an equivalent interpolation assuming no background grid

Using monthly grids
The same approach described above can also be used to derive dekadal rainfall estimates from dekadal station data and monthly background grids.

For each station, the dekadal rainfall is added up for each month to produce a monthly station total. The ratio between the monthly total rainfall (based on gage) and the background grid data is then calculated at the appropriate pixel for each station; then these ratios are interpolated using either the simple IDW or the ordinary IDW as specified by the user. Like before, these ratios are then multiplied by the monthly grid to produce an improved monthly grid (this will be a grid with the suffix M.bil, for example, ire197901M.bil). There is also a grid of ratios between the stations and the rainfall grids (for example, ire197901MR.bil).

The next step is to calculate the ratio between the dekadal and monthly rainfall at each station for each dekad. If the monthly rainfall is 0, make the ratio 0.33. These dekadal-to-monthly ratios are then interpolated. This value of 0.33 is the recommended value to specify for FORCEDLONGRANGEVALDEK if simple IDW is to be used for the dekadal interpolations.

Finally, the grid of interpolated dekad:month ratios are multiplied by the improved monthly grid to produce three dekadal rainfall grids.

List of IRE Parameters
The parameters described above are specified in the IRE algorithm using the following keywords:

•    SEARCHRADIUS 
•    WEIGHTPOWER 
•    MINSTNS 
•    MAXSTNS 
•    MAXEFFECTIVEDIST 
•    MAXRATIO 
•    INTERPOLATIONALGORITHM (idw_o or idw_s)
•    INTERPOLATIONALGORITHMDEK (idw_o or idw_s)
•    FUZZFACTOR 
•    FORCEDLONGRANGEVAL 
•    FORCEDLONGRANGEVALDEK
•    DIAGNOSTICOUTPUTS 
•    UPPERLEFT_XY 
•    LOWERRIGHT_XY 
•    GETMAPLIMITS_FROMVECTORFILE 


	Improving One Rainfall Estimate at a time
	




This methodology allows the improvement of one rainfall estimate at a time. You cannot process data for several dekads at the same time using this methodology; use the Batch Processing Text Editor or the Batch Processing Assistant for running the IRE for many dekads.

On the menu bar, go to Tools > Improve 1 Rainfall Estimates.
The window below appears for the single run IRE calculation. 
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You can run the IRE and configure it so that the output is in the default format for running the GeoWRSI water balance model. This is done by leaving the output filename blank. However, when you do this, you need to specify the date of the file for which you are doing an IRE.

 The specifics of the files are as follows: 

· The Rainfall Station File must be a csv file.
· The csv file must have no header row.
· The columns must be in the order: Longitude, Latitude, Rainfall_Value.
· An example of the format of these files can be found in c:\geowrsi\samples\ire\stations\raingauge2008011.csv.
· The Background Rainfall Raster File must be a .bil file in geographic projection.
You can modify some of the interpolation parameters by clicking the "Advanced Parameters" check box in the top-right corner. This will allow you to change parameters such as
· Power of the weight 

· Minimum and maximum number of stations 

· Search radius 

· Fuzz factor 

· Maximum Effective Distance 

· Maximum Ratio 

· Long Range Value 

· Interpolation Technique 

There is also an option to unbias the rainfall estimates before running the IRE. Check the option to "Unbias before running IRE" to activate this option so that the RFE is unbiased first, then the IRE algorithm is run on the unbiased estimates. The Rainfall Estimate Unbiasing is explained in more detail in the topic Unbiasing Rainfall Estimates.

These parameters are explained in more detail under the topic IRE Algorithm Explained.

In addition, you can define map limits for the interpolation using either an existing vector or raster file, or by zooming in to a specific section on a map. You can do all this when you click the "Define Output Map Limits" check box, then the "Define Map Limits" button.

When you have opted to view the advanced interpolation parameters, defined map limits, and filled all the parameters required, your form will look something like the one shown below.
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You can test try creating the rainfall estimate by following the example shown above.
· For the station file, select: C:\GeoWRSI\Samples\ire\stations\raingauge2008041.csv 

· Select the background rainfall raster file shown above 

· Select "Output Diagnostic statistics" 

· Select "Advanced Options” and 

· Change the Min Stations to 0 

· Change the Max Effective Distance to 100 

· Select the "Define Output Map Limits" then 

· Click the "Define Map Limits" button 

· Click the Browse button in front of the "Select Raster File" text box 

· Select any of the bil files in the "C:\GeoWRSI\Samples\ire\grids\" directory and click OK 

· You should now have a screen that looks like the one above.
When you are finished with this whole process, click the "Process" button. Four windows will pop up: two graphs, one statistical summary text file, and one map, which is the interpolated map. You can  experiment with the parameters to see if you will get any better results. If you run more than once and specify the same output filename, the new summary statistics will be appended to the existing summary file, rather than a completely new file being created.
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	Improving Rainfall Estimates Using the Batch Processing Assistant 
	




This methodology allows the improvement of multiple rainfall estimates at the same time using the Batch Processing Assistant.

The Batch Processing Assistant is a set of forms that help you create a batch file that can be used for running SOS calculations, WRSI calculations, or IRE calculations.

On the menu bar, go to Tools > Batch Processing Assistant. The window below guides you through the process of creating a batch file that will allow you to run the IRE algorithm for several dekads. For the rest of this exercise, we will use the Samples to demonstrate how to use the Batch Processing Assistant to run the IRE.

Select the Option to "Run IRE Interpolation" as shown below, then click "Next." 
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Select the time period. For this example, we will run IRE for dekad 1 of January 2008 to dekad 3 of June 2008. Select the dates as shown in the graphic below, then, click “Next”. Normally, if you are doing improved rainfall estimation for dekads, do not change the “Time Period” section. However, if you are working with days, click on the “Day” option in the Time Period section. In this case we are working with dekads, and no changes are required in the “Time Period” section.
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The next form has many more fields that need to be filled, but it becomes easy after the first few times. 

There are three sections on this form: one section describing the "Grid" data that you are going to use, another section describing the "Station" data that you are going to use, and the last section describing the "Outputs"—where you want them to be and how you want them to be named.
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The Grid Section
Specify the numbers that are considered missing values in your grids. Missing values are usually –999 or –9999 for signed grids. The GeoWRSI allows you to use a range of values as missing values. Any numbers in this range will be ignored in the IRE process. 

In this example, use –9999 for the "FROM" value and –999 for the "TO" value.

Next, specify the "Folder containing Grids." Use the Browse button to the right of the textbox for this entry, then select the appropriate directory. 

In this example, specify the directory C:\GeoWRSI\Samples\ire\grids.

Next, specify the Prefix, the Date Format, and the Suffix of the Grids. 

For this example, these parameters are as follows:

Prefix: ppt
Date Format: 4-digit year; 2-digit dekad (01–36)
Suffix: .bil

For a full explanation of date formats, prefixes, and suffixes, see the topic Understanding date-compatible filenames.

When you have finished filling out the grid part of the form, it should look like this:
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Note: When you are carrying out IRE with data that has already been imported into the GeoWRSI, you can click the GeoWRSI button (shown in the diagram above) to specify the GeoWRSI grid details to be used for IRE.

The Stations Section
The station section describes the station data that you are going to use. There are two options in the formatting of the station data.

Option 1 for station data: Separate files for different dekads
 The first option is to have separate station data in separate files for each dekad. So if you are going to process the IRE for 5 full years, that will be 180 dekads, and you will need 180 different station files. The format of the files should be as follows:
· The Rainfall Station File must be a csv file.
· The csv file must have no header row.
· The columns must be in the order: Longitude, Latitude, Rainfall_Value.
· An example of the format of these files can be found in c:\geowrsi\samples\ire\stations\raingauge2008011.csv.
Obviously, it can take a lot of work to prepare your rainfall data for this format, and unless you have a good reason for preparing your data input in this way, this approach is generally discouraged.

Option 2 for station data: one file for all the station data (all the different dekads)
 The second option is to have all your station data for all the dekads in one file. One of the advantages of this approach is that many people already store their data in this format, in which case it is a question of ensuring that the file is in a format compatible with the GeoWRSI.

Generally, the file should be in a file that can look something like the one below:
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The file should be a plain text file, a csv file with columns separated by commas. Other types of separators will also be acceptable. An Excel file (.xls) file will not work. The columns that the file should have should include:
· A unique station identifier (in the example above, that is the column called "STATION" 

· A longitude column ("LON" in the example above) 

· A latitude column ("LAT" in the example above) 

· An unbroken series of columns from dekad 1 to dekad 36 (in the example above, the columns "Dek1", "Dek2", "Dek3"...,"Dek36"
· A year column that indicates the year the data are for
With these essential columns, the station data can be used in the IRE algorithm by following the steps outlined below. Again, the data in the C:\GeoWrSI\Samples Directory are used. In these examples, the rainfall station data used were kindly made available from the Kenya Meteorological Department.

Fill out the "Stations" section of the form as follows:
At the top-left of the "Stations" section, click the check box "The station data is all in one file" so that the box is ticked. The Stations section on your form should now look like the one below.
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Type in the missing value as –9999 (you may have guessed this from looking at the picture of the csv file in the graphic above). We use this value to represent the fact that we have no data for a specific station for a specific dekad.

Use the "Browse" button to select the "File with all station data." Choose the file: C:\GeoWRSI\Samples\ire\stations\KMDgauge08h1.csv.

Once you have selected the file, you will notice that you are presented with a screen entitled "Define Delimited Data Text File."
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The GeoWRSI here wants you to tell it how the station file you have just selected is organized. To do this, you need to first "Select Row with Header (which in this case, is row 1), then "Select First Data Row" (which in this case is row 2), and finally "Select Delimiter" (which in this case is a comma).

You can select the rows by either pressing the button then selecting the appropriate row, or by typing "1" in the Header Row textbox and "2" in the "First Data Row" text box (type the numbers without the quotation marks).

If you click the buttons for selecting rows, you will get a form that looks like the one below.
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Just select the requested row (in the case shown in the graphic above, the software is asking you to "Select Row With Header Columns") and click OK. The number of that row will appear in the box. 

After you have done all the selections, the "Define Delimited Data Text File" form should look like the one below.
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Click OK to return to the Batch Assistant.

The next step is to specify the columns with station ID, latitude, longitude, year, dekad 1, and dekad 36. To assist you in selecting these columns, click on the text box for defining any of those required parameters. You will get a drop-down list with the names of all the columns in the station file. Select the appropriate column name. An example of this is shown below.
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After you have made the selection, the column number for that particular column will be put in the text box for that parameter.

When you have finished specifying all the parameters, your station section should look like the graphic below.
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Finally, you can fill in the outputs section. This part is up to you where you want the outputs to be, but make your outputs section look like this for the sake of the exercise.
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NOTE
If you click on the "Output Diagnostic Statistics" check box so that it is ticked, the algorithm will also output several statistics that allow you to quantify how much value-addition you got out of your interpolation.

If you click the "Advanced Options" check box so that it is ticked, you get several more options that allow you to control the quality of the interpolation and to crop the interpolation so that you can produce a grid of a smaller area that may be your area of interest. For more information on the parameters for controlling the interpolation, read the topic Creating Improved Rainfall Estimates using a modified IDW Interpolation Technique. The main parameters that can be changed include:
· Power of the weight 

· Minimum and maximum number of stations 

· Search radius 

· Fuzz factor 

· Maximum Effective Distance 

· Maximum Ratio 

· Long Range Value 

· Interpolation Technique 

· Whether to unbias the RFE before implementing IRE (see the topic Unbiasing Rainfall Estimates for more details)
After making all the changes and entering values for the IRE, your form should look like the one below.
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The example does not define any map limits. This is not necessary in this example because the maps themselves are quite small, but in other circumstances, you may find this feature useful. By default, the output files will have the same dimensions as the original rainfall estimate grids that are being "improved." So for example, if the background rainfall grid is the rainfall estimate for all of Africa, but you only have station data covering Kenya, then it does not make sense to create an output grid over the whole of Africa. In such a case, it would be appropriate to define map limits that cover only the Kenya area.

When you are satisfied with your form, you can click "Finish," and the GeoWRSI will generate a batch file for you that describes all the settings you configured in the Batch Assistant, but in a language that the GeoWRSI understands. 
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Save the batch file (it is recommended to save it to the directory C:\GeoWRSI\Samples\ire\batch\; you can call the file irekenya.gbl), then run it using the menu commands Run > Run Batch File.

A progress window will appear which will show the progress of the interpolations. When it has finished (it will indicate this with the word "Done"), you can click the "Close" button.

The outputs should be in the output folder that you specified in the Batch Assistant.
	Creating Improved Rainfall Estimates Using Batch Commands
	






The IRE batch commands allow you to run the IRE using a script language. This allows you to process IRE for many dekads with relatively little effort. You just write the program and specify how many dekads (up to thousands) it should run for, and then leave it running. 

If you have already read the topic on running the IRE using the Batch Processing Assistant, you may have realized that you can use the Batch Assistant to create a batch file for you, then modify the batch file using the Batch Text Editor. This is probably the easiest way of working with batch files. However, some IRE commands are not available from the Batch Assistant, and hence the need for this separate topic.

There are four ways of writing the IRE batch commands. 

(1) 
IREGEOWRSI DATE yyyy/mm/d STATIONFILE csvfile GRIDFILE bilfile 
(2) 
IRE STATIONFILE csvfile GRIDFILE bilfile OUTPUTFILE outputfile 
(3)
  

BEGIN IRE
  STATIONFOLDER 
  STATIONPREFIX 
  STATIONDATEFORMAT 
  STATIONSUFFIX 
  DELIMITER 
  GRIDFOLDER 
  GRIDPREFIX 
  GRIDDATEFORMAT 
  GRIDSUFFIX 
  DATEBRACKET FROM yyyy/mm/d TO yyyy/mm/d 
  OUTPUTFOLDER 
  OUTPUTPREFIX 
  OUTPUTDATEFORMAT 
  OUTPUTSUFFIX 
  MISSINGVALUERANGE 
END IRE

(4) 
 
BEGIN IREGEOWRSI
  STATIONFOLDER 
  STATIONPREFIX 
  STATIONDATEFORMAT 
  STATIONSUFFIX 
  DELIMITER 
  GRIDFOLDER 
  GRIDPREFIX 
  GRIDDATEFORMAT 
  GRIDSUFFIX 
  DATEBRACKET FROM yyyy/mm/d TO yyyy/mm/d 
  MISSINGVALUERANGE 
END IREGEOWRSI 


Where 
IRE and IREGEOWRSI are the batch commands. 
YYYY is the year, in 4-digit format (for example, 1993 is written as 1993, not 93). 
MM is the month, in 2-digit representation (between 01 and 12). 
D is the dekad between 1 and 3. 
csvfile is the file containing the rain gage station data for the date described. 
bilfile is the grid/raster file for rainfall that will be co-interpolated with the rain gage data. It will normally be rainfall for the corresponding date as a raster/grid file and should be in the ESRI BIL format with an accompanying header. 

The command IREGEOWRSI will place the output directly into the GeoWRSI precipitation data directory in the GeoWRSI data format. 
The command IRE will allow the user to select the output folder for files and the file naming convention to be used for the output files. 

The precommand BEGIN signifies a loop for either the IRE or the IREGEOWRSI command and is especially useful when all the stations are in one directory, all the grids are in one directory, and all the files have a common file naming convention. The user just specifies then the span of dates (DATEBRACKET) for which to do the co-interpolation. This saves having to write each command repeatedly (suppose you need to co-interpolate 300 dates). Each BEGIN precommand should be accompanied by a corresponding END command, and all the stated subcommands should be given. 

STATIONFOLDER, STATIONPREFIX, STATIONDATEFORMAT, STATIONSUFFIX, GRIDFOLDER, GRIDPREFIX, GRIDDATEFORMAT, GRIDSUFFIX, DATEBRACKET FROM TO, OUTPUTFOLDER, OUTPUTPREFIX, OUTPUTDATEFORMAT, and OUTPUTSUFFIX are subcommands for the loops. These allow the definition of various parameters to allow the loop to happen. A space should be placed between each subcommand and its parameter. If a parameter contains spaces (for example, a folder name with spaces in it such as "c:\Documents and Settings\"), it should be placed in quotation marks. 

The subcommands for the BEGIN IRE and BEGIN IREGEOWRSI commands are further explained below. 

BEGIN IRE 
  STATIONFOLDER afolder (use quotation marks if there are spaces in the folder path 
  STATIONPREFIX aprefix (* for nothing) 
  STATIONDATEFORMAT adateformat (can be: YYYYEK, YYEK, YYYYMMK, YYMMK 
  STATIONSUFFIX asuffix (* for nothing) 
  DELIMITER (comma by default. put "," or COMMA or TAB or "." or ";" or whatever it is
  GRIDFOLDER afolder (use quotation marks if there are spaces in the folder path 
  GRIDPREFIX (* for nothing) 
  GRIDDATEFORMAT (can be: YYYYEK, YYEK, YYYYMMK, YYMMK 
  GRIDSUFFIX (* for nothing) 
  DATEBRACKET FROM yyyy/mm/d TO yyyy/mm/d (The year, yyyy, must be written in 4 digit format, and the month, mm, must be written in 2 digit format. There should be no spaces between yyyy and mm, nor between mm and d) 
  OUTPUTFOLDER afolder (use quotation marks if there are spaces in the folder path 
  OUTPUTPREFIX (* for nothing) 
  OUTPUTDATEFORMAT (can be: YYYYEK, YYEK, YYYYMMK, YYMMK 
  OUTPUTSUFFIX (* for nothing) 
  MISSINGVALUERANGE value1 value2 (a range encapsulating any numbers that should be treated as missing values in the grid. Default is -9999 to -999. If only one value is specified, that will be used as the missing value) 
END IRE 

BEGIN IREGEOWRSI 
  STATIONFOLDER afolder (use quotation marks if there are spaces in the folder path 
  STATIONPREFIX (* for nothing) 
  STATIONDATEFORMAT adateformat (can be: YYYYEK, YYEK, YYYYMMK, YYMMK 
  STATIONSUFFIX (* for nothing; should include the extension) 
  DELIMITER (comma by default. put "," or COMMA or TAB or "." or ";" or whatever it is
  GRIDFOLDER afolder (use quotation marks if there are spaces in the folder path 
  GRIDPREFIX (* for nothing) 
  GRIDDATEFORMAT adateformat (can be: YYYYEK, YYEK, YYYYMMK, YYMMK 
  GRIDSUFFIX (* for nothing; should include the extension) 
  DATEBRACKET FROM yyyy/mm/d TO yyyy/mm/d (The year, yyyy, must be written in 4 digit format, and the month, mm, must be written in 2 digit format. There should be no spaces between yyyy and mm, nor between mm and d) 
  MISSINGVALUERANGE value1 value2 (a range encapsulating any numbers that should be treated as missing values in the grid. Default is -9999 to -999. If only one value is specified, that will be used as the missing value) 
END IREGEOWRSI 


A batch file processing data from dekad 1 of October 2001 to dekad 1 of January 2002 may look as follows using the IREGEOWRSI command: 
IREGEOWRSI DATE 2001/10/1 STATIONFILE c:\test\ire\stations\gauge01101.csv GRIDFILE c:\test\ire\grid\rain\rfe01101af.bil 
IREGEOWRSI DATE 2001/10/2 STATIONFILE c:\test\ire\stations\gauge01102.csv GRIDFILE c:\test\ire\grid\rain\rfe01102af.bil 
IREGEOWRSI DATE 2001/10/3 STATIONFILE c:\test\ire\stations\gauge01103.csv GRIDFILE c:\test\ire\grid\rain\rfe01103af.bil 
IREGEOWRSI DATE 2001/11/1 STATIONFILE c:\test\ire\stations\gauge01111.csv GRIDFILE c:\test\ire\grid\rain\rfe01111af.bil 
IREGEOWRSI DATE 2001/11/2 STATIONFILE c:\test\ire\stations\gauge01112.csv GRIDFILE c:\test\ire\grid\rain\rfe01112af.bil 
IREGEOWRSI DATE 2001/11/3 STATIONFILE c:\test\ire\stations\gauge01113.csv GRIDFILE c:\test\ire\grid\rain\rfe01113af.bil 
IREGEOWRSI DATE 2001/12/1 STATIONFILE c:\test\ire\stations\gauge01121.csv GRIDFILE c:\test\ire\grid\rain\rfe01121af.bil 
IREGEOWRSI DATE 2001/12/2 STATIONFILE c:\test\ire\stations\gauge01122.csv GRIDFILE c:\test\ire\grid\rain\rfe01122af.bil 
IREGEOWRSI DATE 2001/12/3 STATIONFILE c:\test\ire\stations\gauge01123.csv GRIDFILE c:\test\ire\grid\rain\rfe01123af.bil MISSINGVALUERANGE -9999 
IREGEOWRSI DATE 2002/01/1 STATIONFILE c:\test\ire\stations\gauge02011.csv GRIDFILE c:\test\ire\grid\rain\rfe02011af.bil MISSINGVALUERANGE -9999 -999 

Imagine writing a batch file like this for processing 10 years of data. That is 360 lines you would have to write. 

A batch file processing data from dekad 1 and 2 of October 2001 may look as follows using the IRE command: 
IRE STATIONFILE c:\test\ire\stations\gauge01101.csv GRIDFILE c:\test\ire\grid\rain\rfe01101af.bil OUTPUTFILE c:\output\ire2001101.bil 
IRE STATIONFILE c:\test\ire\stations\gauge01102.csv GRIDFILE c:\test\ire\grid\rain\rfe01102af.bil OUTPUTFILE c:\output\ire2001102.bil 


The loops for the commands above would look as follows: 

BEGIN IRE 
  STATIONFOLDER c:\test\ire\stations\ 
  STATIONPREFIX gauge 
  STATIONDATEFORMAT YYMMK 
  STATIONSUFFIX .csv 
  GRIDFOLDER c:\test\ire\grid\rain\ 
  GRIDPREFIX rfe 
  GRIDDATEFORMAT yymmk 
  GRIDSUFFIX af.bil 
  DATEBRACKET FROM 2001/10/1 TO 2001/10/2 
  OUTPUTFOLDER c:\output\ 
  OUTPUTPREFIX ire 
  OUTPUTDATEFORMAT yyyymmk 
  OUTPUTSUFFIX .bil 
  MISSINGVALUERANGE -999 
END IRE 

Note that you don't have to specify the date for the IRE command because the output file has been specified already (the date is used to create the output file), but you do need to specify the date information for the IRE loop because the output filename is created automatically, and the easiest way of doing this is to use the dates. 

BEGIN IREGEOWRSI 
  STATIONFOLDER c:\test\ire\stations\ 
  STATIONPREFIX gauge 
  STATIONDATEFORMAT YYMMK 
  STATIONSUFFIX .csv 
  GRIDFOLDER c:\test\ire\grid\rain\ 
  GRIDPREFIX rfe 
  GRIDDATEFORMAT yymmk 
  GRIDSUFFIX af.bil 
  DATEBRACKET FROM 2001/10/1 TO 2002/01/1 
END IREGEOWRSI 

For the example given above, to process 10 years of data, you would simply have to change the IREDATEBRACKET parameter and then go for a coffee break while the computer processes the data, or you could simply open another program and work on that. 


The format of the csv file is as follows: 

longitude1, latitude1, value1 
longitude2, latitude2, value2 
longitude3, latitude3, value3 
longitude4, latitude4, value4 
... etc... 

where 
longitude1 is the longitude for station 1 
latitude1 is the latitude for station 1 
value1 is the rainfall value for station 1 in the dekad specified by YYYY,MM,D 

There should be no headers or descriptive text in the csv file. It is just a list of station longitudes and latitudes and their rainfall values. 

An example of a csv file would be: 
29.5, -21.5, 0 
29.9, -22.9, 10.3 
28.7, -21.0, 5.1 
29.2, -19.8, 0 
31.8, -22.1, 0.1 
28.4, -22.2, 7.5 
Specifying file details for a single station file that contains all the station data
You can use more advanced IRE commands by specifying a data file that has all the data for all the dates. The details for this file need to be specified as follows: 

BEGIN FILEDETAILS 
  DELIMITER ("space" or "comma" or "semicolon" or " " or "," or ";") [Note: Be sure to use quotation marks here] 
  MISSINGVAL a missing value used in the stations file (e.g. - 999) 
  NUMHDRLINES numlines 
  STNIDCOL colnum 
  LONGCOL colnum 
  LATCOL colnum 
  ALTCOL colnum 
  YEARCOL colnum 
  DEK01TO36COLS colnum1 colnum36 
  DEK01TO18COLS colnum1 colnum18 
  DEK19TO36COLS colnum19 colnum36 
  DEK01COL colnum 
  DEK02COL colnum 
  DEK03COL colnum... 
END FILEDETAILS 
This code can be inserted into the IRE or the IREGEOWRSI command together with a MULTISTATIONFILE subcommand, specifying the name and the path of the file with multiple dates. 
The following commands are optional; you only have to choose some of them based on the structure of your file. If your file has all the dekads in columns going from dekad 1 to dekad 36, you can use the command DEK01TO36COLS and specify the column number for dekad 1 and the column number for dekad 36. On the other hand, if your file starts in dekad 19 (July dekad 1), then you can specify DEK19TO36COLS and then DEK01TO18COLS. 

Thus, the full command could look like this: 


BEGIN IREGEOWRSI 
  MULTISTATIONFILE c:\test\ire\stations\rain1951to2007.csv 
  BEGIN FILEDETAILS 
    DELIMITER "comma" 
    MISSINGVAL -999 
    NUMHDRLINES 1 
    STNIDCOL 2 
    LONGCOL 3 
    LATCOL 4 
    ALTCOL 5 
    YEARCOL 42 
    DEK01TO36COLS 6 41 
  END FILEDETAILS 
  GRIDFOLDER c:\test\ire\grid\rain\ 
  GRIDPREFIX rfe 
  GRIDDATEFORMAT yymmk 
  GRIDSUFFIX af.bil 
  DATEBRACKET FROM 1995/01/1 TO 2002/12/2 
  MISSINGVALUERANGE -999 
END IREGEOWRSI 
As the name of the station data file suggests, that file probably contains data for all the years between 1951 and 2007. However, from the DATEBRACKET command, only the years 1995 to 2002 will be processed. 

More advanced IRE commands 
More advanced IRE commands can be used to alter the way in which the IRE will be run. These commands are listed below.
  SEARCHRADIUS <value_in_km>
  WEIGHTPOWER <value_eg_2_is_recommended>
  MINSTNS <min_num_stations_for_calculating_interpolated_value>
  MAXSTNS <max_num_stations_for_calculating_interpolated_value>
  MAXEFFECTIVEDIST <value_in_km>
  MAXRATIO <value_3_is_recommended>
  INTERPOLATIONALGORITHM <idw_o or idw_s>
  INTERPOLATIONALGORITHMDEK <idw_o or idw_s>
  COINTERPOLATIONTYPE <ratio or ratio_and_anom>
  FUZZFACTOR <value_1_is_recommended>
  UNBIASRFE <True/False>
  FORCEDLONGRANGEVAL <value>
  FORCEDLONGRANGEVALDEK <value>
  DIAGNOSTICOUTPUTS <True/False>
  OUTPUTSTATSFILE <put_output_file_for_statistics_here>
  UPPERLEFT_XY <x_value> <y_value>
  LOWERRIGHT_XY <x_value> <y_value>
  GETMAPLIMITS_FROMVECTORFILE <vector_file>


These commands are explained below.
· SEARCHRADIUS: The maximum radius (in km) over which to search for stations that will be used in the interpolation of each pixel. If, at a pixel, the distance to a station is larger than SEARCHRADIUS, then that station will not be used in the interpolation at that pixel.  

· WEIGHTPOWER: The power that will be applied to the inverse distance in calculating the weight. For example, a weight of 2 means that the inverse distance to each station will be squared (power of 2) to calculate the weight to that station. 

· MINSTNS: The minimum number of stations to be used in the interpolation. If there are less than MINSTNS available at a point, that pixel will not be interpolated, and a missing value will be put in the output grid at that pixel. Use a value of MINSTNS = 0 to produce a value everywhere in the output. 

· MAXSTNS: The maximum number of stations to be used in the interpolation. For example, if MAXSTNS = 10, and if there are more than 10 stations available at a point for the interpolation, only the nearest 10 stations will be used in the interpolation.  

· MAXEFFECTIVEDIST:  This parameter only works with the "Simple IDW" (idw_s). It is the distance that is assigned to the a priori value in the interpolation. The a priori value is analogous to an invisible point that is always present everywhere in geographic space covered by the interpolation and is always a distance = MAXEFFECTIVEDIST away from any point. 

· MAXRATIO: The maximum station/grid value that is allowed in the interpolation. When the station/grid ratio is greater than MAXRATIO, then the MAXRATIO value is used. 

· INTERPOLATIONALGORITHM: The type of interpolation algorithm to use, namely idw_o or idw_s. idw_o is ordinary inverse distance weighting (IDW) interpolation, in which the interpolation weights are dependent only on the surrounding stations. idw_s is simple IDW, in which the backgtound grid also contributes a weight to the interpolation routine, and the relative weight of the background grid increases increasing distance to surrounding stations. 
· COINTERPOLATIONTYPE: two options are available: (a) RATIO and (b) RATIO_AND_ANOM. In the RATIO option, the ratio of the measured station rainfall value to the RFE value is calculated at all the station locations, the ratios are interpolated, and the interpolated ratios are then multiplied by the original RFE to produce the improved RFE. In the RATIO_AND_ANOM option, the same procedure is done as in the RATIO option, but a second step is added. In this second step, anomalies are calculated between the original rain gage station values and the ratio-interpolated grid at all the station locations. These anomalies are interpolated, and the interpolated anomalies are then added to the ratio-interpolated grid to produce a final product 

· FUZZFACTOR: A distance, in diagonal pixel units, which allows the at-station pixel values to be "fuzzed" so that the final product does not interpolate exactly to the station value. In the interpolation, no station can be closer than the fuzzfactor distance in diagonal pixel units. 

· FORCEDLONGRANGEVAL: The Forced Long Range Value is the value toward which the interpolated value tends in the increasing absence of any nearby stations. It is used in conjunction with the MAXEFFECTIVEDIST in "Simple IDW" and is the "a priori value" referred to in the MAXEFFECTIVEDIST documentation. 

· DIAGNOSTICOUTPUTS: True or False. If you specify True, the program will generate statistics that will give some indication of how good the interpolation is and how good was the original relationship between the original RFE and the station data. The graphic showing the improved RFE will also be displayed with the station locations and values superimposed. 

· OUTPUTSTATSFILE: The file containing all the diagnostic statistics. 

· UNBIASRFE: True or False. Indicates whether to unbias the RFE grids before improving them. See the topic Unbiasing Rainfall Estimates for more details on how the GeoWRSI performs RFE unbiasing.

· UPPERLEFT_XY: The longitude and latitude of the upper left corner of the output grids. If this parameter is omitted, the output grid will default to the same as the original RFE. 

· LOWERRIGHT_XY: The longitude and latitude of the lower right corner of the output grids. If this parameter is omitted, the output grid will default to the same as the original RFE.  

· GETMAPLIMITS_FROMVECTORFILE: A filename of a shapefile from which to extract the upper left and lower right corner of the output grids.  
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Rainfall estimates sometimes have an inherent systematic bias in the way that they are calculated. In this scenario, it can be useful to unbias the rainfall estimates so that they provide a more accurate representation of the actual rainfall. When such a scenario avails, one way of unbiasing the rainfall estimates is to divide the rainfall estimate by the ratio of the true average rainfall for that period to the average rainfall estimate (RFE) for the same period.

  unbiased_RFE = RFE * (true_average_rainfall / RFE_average)
In areas where the rainfall averages are low, the ratio between the true_average_rainfall and the RFE_average can become very high and cause unrealistically high results. To counter this, the maximum allowable value of the ratio of true_average_rainfall :RFE_average is limited to 3; any ratio above this is revised to the maximum value before multiplying by RFE to calculate unbiased_RFE

In the GeoWRSI, grids have been prepared for this unbiasing procedure. These grids need to be downloaded and installed into the GeoWRSI before the unbiasing procedure can be used. 

The unbiasing grids for Africa can be downloaded at ftp://hollywood.geog.ucsb.edu/pub/geowrsi. The file that needs to be downloaded is unbiasing2007_Africa.zip. This file may be updated to 2008 and 2009. Watch this ftp site for the inclusion of other unbiasing files in the future.

After downloading the unbiasing files, you can install them into the GeoWRSI using the menu sequence Tools > Install Rainfall Unbiasing Files. Specify the file you downloaded as the "Unbiasing Zip File."

If you are working with a dataset other than the NOAA RFE 2.0, you can create your own unbiasing zip file that can be installed into the GeoWRSI and used in the GeoWRSI. If you are going to use the NOAA RFE 2.0 rainfall datasets, you can skip this paragraph. To make your own unbiasing zip file, create a set of dekadal rainfall estimate average grids, one average for each dekad, and put them in a directory called "unbiasing\rfeavg." These grids should be in Geographic projection and in the bil format. They should have the file naming convention rfeavg01.bil to rfeavg36.bil. Using the same format, prepare a set of dekadal "best rainfall average" grids, using all the available rainfall data and the most rigorous interpolation techniques available. These files should have the same dimensions as the rainfall estimate average grids described earlier. Put these files in a directory "unbiasing\fclimdk," and the files should have the file naming convention fclimdk01 to fclimdk36. Alternately for this "best rainfall averages," you can use the files that come with the unbiasing zip file that is downloaded if you are doing the analysis for Africa. When you have gotten these instructions done, zip up the "Unbiasing" directory into the file Unbiasing*.zip. You can replace the "*" with any descriptive text of your choice, or you can just call it "unbiasing.zip" if you like. Once you have your unbiasing zip file, you can install it into the GeoWRSI using the menu sequence Tools > Install Rainfall Unbiasing Files. 

Example

There are several ways to access the RFE unbiasing procedure. One of these ways is through the IRE algorithm, by specifying that the rainfall estimates should be unbiased before running the IRE. The second way is to unbias the grids directly. This can be done either by writing a batch file in the Batch Processing Text Editor or by using the Batch Processing Assistant to write the batch file for you. The following text will describe the procedure for doing the rainfall estimate unbiasing using the Batch Processing Assistant. You can follow the example below using the samples in the directory C:\GeoWRSI\Samples. If you have not already downloaded and installed the samples, you can download them at ftp://hollywood.geog.ucsb.edu/pub/geowrsi (the file is called Samples.zip), and install them using the menu sequence Tools > Install Samples Folder. You will also have to download and install the unbiasing files if you have not done that already, using the instructions described above.

Click the menu sequence Tools > Unbias Rainfall Estimates. You will be redirected to step 1 of the Batch Assistant with the "Unbias RFE" option selected.
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Click next, then specify the dates for the unbiasing. For this example, select to do the unbiasing from dekad 1 of January to dekad 3 of June 2008 as shown below.
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Click next. You will be taken to Step 3 of the Batch Assistant, which for unbiasing, will ask you to specify the folder, prefix, date format and suffix of the RFE grids, the missing value range, and the folder, the prefix, date format and suffix of the outputs that will be produced by the unbiasing algorithm. For this exercise, you can fill out the form as shown below, then click finish. If you leave the Outputs section blank, the outputs will be saved to the GeoWRSI data directory so that they can be used immediately for running the water balance functions.
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You will be redirected to the Batch Processing Text Editor, with all your specifications converted to GeoWRSI batch code. In the Editor, press F5 to start running the batch file (or the menu sequence Run > Run Batch File). It is better though to save the batch file before running so that you can always refer to the batch file later.

You can see your outputs in the outputs folder that you specified, and you can view them using any gis image viewer or the Spatial Data Viewer in the GeoWRSI.
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Introduction to Batch Processing
Batch processes are instructions or commands, often repetitive and tedious, that are given to the computer so that it repeatedly processes the instructions automatically without too much user intervention required. For example, suppose you want to calculate WRSI for each year from 1971 to 2005. You could write 35 separate instructions to the computer, which may look something like this:

Calculate WRSI for 1971
Calculate WRSI for 1972
Calculate WRSI for 1973
...
Calculate WRSI for 2005



Or can give the computer one instruction which would allow it to process all 36 instructions:

Calculate WRSI for 1971 to 2005

The computer would then translate to the 36 instructions to Calculate WRSI for each of the years.

These instructions often need to be written in a very specific way so that the program that is interpreting the instructions does not get confused by ambiguous statements. The exact way of writing instructions, and the instructions that can be written, will differ from program to program. 

A set of instructions that is written in a batch file is often referred to as "code."

Batch Processing in the GeoWRSI
In the GeoWRSI, several operations can be run using the batch processing:

· Calculating Water Requirements Satisfaction Indices (WRSI values) for several seasons, or using several different settings and scenarios, all at one go 

· Calculating for start of season (SOS) for several seasons, or using several different settings for the same season, all at one go 

· Calculating rainfall estimates using the Improved Rainfall Estimation (IRE) algorithm for several (hundreds) of dekads at one go 

· Validating rainfall estimates for several (up to hundreds) of dekads 

· Unbiasing rainfall estimates for several dekads 

· Doing simple interpolations for several dekads 

· Performing simple algebraic operations
To carry out batch processing, you need to write out the code. There are a few options available for writing out the code.

1.  Using the Batch Processing Assistant, which creates the code for you when you tell it what you want to do
2.  For users who are more comfortable with the GeoWRSI Batch Language, another option is using the Batch Processing Text Editor 

3.  Using any text editor software, such as Notepad or Wordpad (not recommended)

Which option to use depends on what you want to do, but for most users, using the Batch Processing Assistant is the recommended approach.
	Batch Processing Text Editor
	




This menu item allows you to open a batch file (*.gbl) or create a new one using the GeoWRSI Batch Processing Text Editor. The GeoWRSI Batch Text Editor (shown below) is an environment that has been customized to help you edit or create a GeoWRSI batch file. You can create a batch file to run the WRSI, SOS, IRE, or Grid Calculations. 
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To open the Batch Processing Text Editor, do the following procedure:
1.  On the menu bar, go to Tools > Batch Processing Text Editor
2.  A dialog will appear as shown below
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3.  At this point you have two choices:
    a.  Open an existing batch file by selecting a batch file that already contains code that you want to run, or modify and run
    b.  Create a new batch file by pressing Cancel, which will take you to the Batch Text Editor so that you can write out the code

1. Open a Batch File
· The initial dialog that comes up is the usual "File Selector" dialog
· Navigate to the location of the batch file and select it
· Click Open
2. Create a new Batch File
· Click Cancel in the "File Selector" dialog when it appears
· This takes you to the Text Editor with a blank screen
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The GeoWRSI Batch Text Editor has various functions that you can use to make the process of creating batch files easier.
· These functionalities are conveniently located under a few menu items.

· The File menu gives you the following functionalities:

Open - To open an existing batch file

New - To create a new batch file

Save - To save the code that you have written
Save As - To save the code that you have written to another file
Exit After Run - To instruct the program to exit the batch text editor after the batch file has finished running

Exit - To exit the Text Editor

· The Edit menu gives you the functionalities usually found under such a menu—undo, redo, cut, copy, paste.

· The Run menu allows you to run the batch file. You can also press the F5 key to run the batch file.

The Tools Menu: Inserting Code Templates and Session Values
· The following items can be inserted into your code without having to type them in:

1. An Existing Region 

2. An Existing Crop 

3. An Existing File 

4. An Existing Folder 

5. A Dekadal Date Format 

6. A Dekadal Date 

7. Map Limits

· The Tools menu also has a submenu labeled Insert Code Templates.

· This submenu provides you with templates of code that you can insert.

· These templates of code insert text into the text editor which you simply write over, placing your own values.

· A simple example of text that may be inserted is shown below.

BEGIN CALCSOS
  REGION <put_existing_region_here>
  SOSDEF CALCULATED rain DEKAD1THRESHOLD 25 DEKAD2PLUS3THRESHOLD 20 IGNORECLIMSOS false MAXDEKSEARLY 3 <or_SOSOFFSET_value_or_SOSDEKAD_value_or_AVERAGE_or_EXISTINGFILE_filename>
  WHCDEF default <or_EXISTINGFILE_filename_or_MILLIMETERS_value>
  INITIALYEAR <put_year1_here> <put_year2_here> <put_year3_here> <put_year_etc_here>
  OUTPUTFOLDER <put_output_folder_here>
  OUTPUTFILEPREFIX "*"<or_other_file_prefix>
END CALCSOS
· The template has portions that have angled brackets.

· When you are replacing and placing the values that you want to specify, also remove the angled brackets.
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The Batch Processing Assistant is accessed by running the menu sequence Tools > Batch Processing Assistant. 
· The purpose of the Assistant is to help you create a batch file that the GeoWRSI can understand.
· Follow the instructions as they are displayed and select the options that you want to be included in the batch file.
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· Above is the first dialog that you will see.
· In Version 2 of GeoWRSI, you can run several processes in batch mode, including:
            -Calculating WRSI

            -Calculating SOS

            -Running IRE interpolation
            -Validating RFE
            -Unbiasing RFE
        

For example, if you select "Calculate WRSI," then the rest of the steps are as follows:
1. Specify the list of years for which you want the WRSI runs to be done
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2. When you click Finish in the dialog that is displayed, the Batch Text Editor opens with the processes that you specified to be run.
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3. You can do any edits you require and save the batch file. Perform the Run command in the Batch Editor and wait for the process to be completed. The Progress Indicator will indicate "Done" and "Close" when the process is complete.

· The progress of the batch processes is shown, as is shown in the example for WRSI batch processing below.
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The outputs will be displayed in the default output directory unless you specify otherwise in the batch file. You can see the default output directory by clicking on the menu item Setup > WRSI Output Folder. 
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The WRSI batch commands allow you to calculate the SOS and WRSI using a simple script language. This allows you to run the WRSI and SOS for many seasons at one go with relatively little effort. You just write the program and specify how many seasons it should run for, and then leave it running. For example, with a 3-line script, you can run the WRSI for 50 years and produce 50 WRSI images, as long as you have 50 years of GeoWRSI-compatible rainfall data (you can produce these using the IRE process).
There are two basic commands for calculating WRSI-based parameters in the GeoWRSI script language: calcwrsi and calcsos. 

Calcwrsi
The calcwrsi command is outlined below.

Full set of possibilities available with calcwrsi

BEGIN CALCWRSI
    STOPAT finaldekad (or_CURRENTDEKAD_or_SIMULATEDCURRENTDEKAD_value_or_DEKAD_value>
    REGION <put_existing_region_here>
    CROPTYPE <put_existing_crop_here_eg_maize>
    GROWINGPERIOD default <or_EXISTINGFILE_value_or_NUMBEROFDEKADS_value>
    SOSDEF CALCULATED rain DEKAD1THRESHOLD 25 DEKAD2PLUS3THRESHOLD 20 IGNORECLIMSOS false MAXDEKSEARLY 3 EXCLUDEINCOMPLETEAREAS True/False INCOMPLETENESSTHRESHOLD 90 <or_SOSOFFSET_value_or_SOSDEKAD_value_or_AVERAGE_or_EXISTINGFILE_filename>
  or...
    SOSDEF CALCULATED SOILMOISTURETHRESHOLD 30 IGNORECLIMSOS false MAXDEKSEARLY 3
    CROPFAILURE WRSITHRESHOLD 30 <or_SOILMOISTURETHRESHOLD_5> RECALCSOSAFTERFAIL True/False PCLGPRESTARTLIMIT 40
    WHCDEF default <or_EXISTINGFILE_filename_or_MILLIMETERS_value>
    PETDEF current <or_AVERAGE>
    PRECIPDEF current <or_AVERAGE>
    INITIALYEAR <put_year_here>
    OUTPUTFOLDER <put_output_folder_here>
    OUTPUTFILEPREFIX "*"<or_other_file_prefix>
END CALCWRSI
Notes
- The regions and crop types that you should specify are those that exist in the program already. You can select these from the menu by using the menu command Tools > Insert Existing Region and Tools > Insert Existing Crop. 

- If there are spaces in any of the parameters (for example, the filenames), they need to be placed in quotes.

- The parameters specified in the "calcwrsi" command are only those that you want to change. If any are left out, the program will run using the last parameters used in the previous run.
- The main requirements are that a "begin calcwrsi" statement should have a corresponding "end calcwrsi" statement.

- The indentation is optional (be sure to use spaces not tabs) and only meant for readability of the code. You don't have to use them. 

- If you had an outputfileprefix in a previous setup, and you now want to remove it, use the subcommand: outputfileprefix *

Examples
begin calcwrsi
  stopat finaldekad
  region "Southern Africa"
  croptype Maize
  growingperiod default
  sosdef Calculated rain dekad1threshold 25 dekad2plus3threshold 20 ignoreclimsos False maxdeksearly 4
  whcdef Default
  petdef Current
  precipdef Current
  initialyear 2006
  outputfolder "c:\test\geowrsi\"
  outputfileprefix ""
end calcwrsi
begin calcwrsi
  initialyear 2001 2002 2003
end calcwrsi
Some Explanations
"petdef current" means run GeoWRSI using current PET.
"sosdef calculated rain dekad1threshold x dekad2plus3threshold x2" means the definition of SOS is such that the SOS should be "calculated" by the program using a "rain" thresholding technique in which the SOS is defined by three consecutive dekads in which "dekad1threshold" is at least x mm and "dekad2plus3threshold" is at least x2.

Full set of possibilities for the calcsos command
begin calcsos
  region "Central America 1", "Southern Africa", "East Africa (Mar-Sep)", "East Africa (May-Nov)", "East Africa (Oct-Feb)", "West Sahel Africa"
  sosdef sosoffset x, Calculated <<rain dekad1threshold x dekad2plus3threshold x2>, <soilmoisturethreshold x>, ignoreclimsos True/False, maxdeksearly x>
  whcdef default, existingfile x, millimeters x
  initialyear year1 year2 year2 etc
  outputfolder x
  outputfileprefix t1
end calcsos
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After initializing and performing a run of WRSI, you can process these results using the Water Balance Yield Estimator, which allows you to run yield regressions and produce estimates based on these regressions.

What is the Water Balance Yield Estimator? 
The Water Balance Yield Estimator (WBYE) is a program that facilitates yield modeling and estimation from some water balance models.

Objective 

The WBYE uses outputs from a water balance modeling program and reformats them into summaries that are compatible with historical yield records. It can be used to facilitate yield modeling and yield estimation from water balance models. The program has three primary uses: 

1. Combined analysis of historical yield records and historical water balance analyses for regression modeling, producing yield regression models. This regression modeling would result in yield estimation models. 

2. Calculating summaries from water-balance analyses for specific regions of interest such as districts, provinces, or countries. 
3. Estimating yield and production using current-season water balance modeling results and the yield regression models developed by the WBYE
Purpose of the WBYE 

After running a WRSI, which is an example of a water balance modeling program, the outputs from the GeoWRSI are geospatial datasets that are in raster grid format . These outputs are generally not compatible with historical yield data, which tend to be produced and archived by administrative units such as provinces and districts. Because of this difference, translating the outputs from these water balance models into a format that can be used directly for yield estimation is a laborious and time-consuming process. The WBYE considerably simplifies this process by enabling the user to select outputs from the water balance models and automatically reformat these outputs into a format compatible with historical yield records. It also combines the water balance outputs with the historical yield records. It then allows the user to create regressions between various water balance parameters and yield or production.

Methodology: GeoWRSI yield estimation
The GeoWRSI produces a set of raster grids, each grid containing information on a specific water balance parameter. The following process is then undertaken in the WBYE with water balance parameters selected by the user: 

1. Calculate the average value of the water balance parameters for each polygon from a map which the user specifies 

2. Combine these average values with historical yield stats from a separate data file (but the yield stats have to be for the same districts that the AMS averages were calculated for) 

3. Perform yield regressions 

 

Program operation 
To operate the program, go to Tools > Water Balance Yield Estimator.
1. The user chooses whether to develop a model (requires historical yield data) or to run a model. 

2. The user selects the directory with the input files and the directory where the outputs should be placed. 

3. The user selects the map file containing the administrative regions or other regions of interest that the outputs should be summarized by. 

4. The user specifies a file with the “years” information (the years which the program should process outputs for). In the case where a season cuts across two years, the “year” specified should be the year in which the season begins. 

5. The user specifies the path of the Windisp program. 

6. If the user has opted to develop a model, the user needs to specify the file containing yield information. 

7. The user can select which water balance parameters should be postprocessed. 

8. Once all the inputs have been defined, the program automatically carries out the processing described in the methodology section and produces the relevant outputs as specified by the user. 

9.  The outputs are passed to a statistical interface to allow for yield modeling. 

Each time the WBPP is launched, it automatically loads the last settings that the user specified the last time the program was run. The user can also save the settings (1 to 8 as described above) for future reference or future rerunning of the program and can opt to load saved settings.

Dependencies: system requirements 
1. Operating system: Windows 200, Windows XP. The program has not been tested on Windows Vista.
2. .net Framework 2.0 Service Pack 1
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The Water Balance Yield Estimator (WBYE)provides functionality for making yield regression models using outputs from the GeoWRSI as variables in the regression model, and for making yield and production estimates from these models.

There are four basic steps in using the WBYE. The first of these steps is done in the GeoWRSI, but the last three are done in the WBYE.

1. Run the GeoWRSI for several years for which you have historical crop statistics data
2. Import historical crop statistics data into the WBYE
3. Develop regression models for the admin units used in the crop statistics data
4. Estimate yield and production for a season of interest
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Before regressions between yield and water balance parameters can be developed, the yield data first need to be ingested into the GeoWRSI crop database. The crop database is ideally not suited for maintenance, because the functions included in this routine are not comprehensive enough to maintain a crop database. The steps for importing the data are outlined below.

First, open the menu item Data > Crops > Import Crop Data.


[image: image70]

You will be presented with the form for importing historical crop data. The form looks like the one below, except that the fields in the form will not be filled. 

Required data format
That data that need to be imported into the GeoWRSI should be a text file in csv format. If you have the data in Excel format, you can save it as csv format. The data should be arranged in three to four columns. The columns can be:
AdminUnit, Yield, Year
or 
AdminUnit, Yield, Area, Year
or 
AdminUnit, Yield, Area, Production, Year
The order and the names of the columns do not really matter, but the data that the columns contain should basically be described by the columns named above.

The crop file must have only one crop type in it. If there is more than one crop type in the file and you import all the data at once, the database will be corrupted, and your regression results will not be correct.

Sample Exercise
As an exercise, you can fill out the form as shown below using the data in the Samples directory. If you have not already loaded the Samples directory, you can download it from ftp://hollywood.geog.ucsb.edu/pub/geowrsi/samples.zip. The file with crop data is MW_HybridMaize1984-2002.csv in the directory c:\GeoWRSI\Samples\wbye\Maize_Agrostats\.
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A few notes
· You cannot specify the production column, the yield column, the area column, the column with feature names, and the column with years until you have specified file with crop data. 

· You can only import one crop type at a time.
· You cannot specify the map field with feature names until you have specified the equivalent map file.  

· The equivalent map file is the vector map file (shapefile or BNA) that most closely corresponds to the administrative units used in the crop data file. As far as possible, the names of the administrative units should be the same in both the crop data file and the vector map file, but this is not a prerequisite.
Defining the season for which the data applies for
The two check boxes specifying whether "the year referred to is the harvest data" and "the growing season cuts across two years" are very important and should be filled out correctly. In the examples shown above, which you can follow using the Samples directory, the answer is "yes" to both questions, so both boxes should be ticked.

Specifying new crop types
You may have noticed that under the option of "Crop Type," you do not have an option of "Hybrid Maize" as is shown in the example. This is because there are options to add new crop types. You can do this using the menu item Data > Crops > Edit Crop Definition Table, then click "Add New" if you want to add the new crop type.

Once you are satisfied with the parameters specified on the form, click the "Import" button. If you have omitted some specifications, the software will prompt you to add them.

Defining matching features when discrepancies arise between the crop data file and the vector file
If there are any discrepancies between the names of admin units specified in the crop data file and the names of admin units specified in the vector file, a pop-up will prompt you to select the matching feature in the vector file which matches the feature specified in the crop data file. This will be similar to the graphic shown below. You will need to select the matching feature then click "OK."  Once these relations are established, they are stored in the database, and as long as you use the same names in the crop files and the same vector files, you will not be prompted again to specify the relationships when you import more data. 

Note that if your crop data and your vector file are perfectly matched, you will not be presented with any of these pop-up forms.
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If you are following the process above using the samples directory, you will get two prompts. Match them as follows:
- "C. Mzimba" matches with "Mzimba Central"
- "S. Mzimba" matches with "Mzimba Central"

Click OK once you have selected the matching feature each time.

As the database is being imported into the database, the software will show you a progress bar. 
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Once the progress bar is complete, you can select a new crop file to import more data as appropriate then click OK, or you can click close if you do not want to import more data.

1. Run the GeoWRSI for several years for which you have historical crop statistics data
2. Import historical crop statistics data into the WBYE
3. Develop regression models for the admin units used in the crop statistics data
4. Estimate yield and production for a season of interest
	Developing Yield Regression Models
	




To develop regression models between the yield data that you will have imported into the database (see the topic on importing crop data into the database if you have not already imported the data) and the outputs from the water balance model, click the "Develop Model" option in the top-right part of the WBYE form. 

Note that it is possible to regress the water balance parameters against any other variable such as production, but generally, yield is the preferred or recommended variable.

You will only be able to use this function after you have run a few years of the GeoWRSI, because the WBYE needs to use the outputs of the GeoWRSI for matching with historical crop statistics. However, you will not be able to use the WBYE if you specified an output file prefix in the GeoWRSI when you were running the model.

Before you develop the regression, you may want to specify which water balance parameters you want to test in the regressions. To do this, use the menu File > Output Options, then select all the parameters that you may want to use later in the regression.
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Samples
If you are following along with the samples in the samples folder, make out the WBYE form so that it looks like the one below. For the years, select 1986 to 1998. The crop type can be hybrid maize, or it can be maize if you had not defined a "hybrid maize" crop in the earlier exercise.
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You will only able to specify the "Years for Processing" after you have specified the “Input working directory." When you click on the "Select Years For Post Processing," you will see a form that looks like the one below. Select the years that you want to use in the model.
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Modeling with or without groups
There are two ways of developing the regression models. In the first method, you can develop a regression model for each separate administrative unit. This is available if you click the option titled "Use Groups in modeling" so that it is not ticked.

The second option allows you to group the administrative units, either by a bigger map, or by clustering similar variables, or even some other groups that you may define. This is the method we shall follow. 

For the samples, after having specified all the required parameters, click "Process." Some numbers will flash showing you the progress of the processing, then when the processing is complete, you will see a form like the one below.
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Group by Map
To group the administrative units by a bigger map, click on the "Group by Map" option, then specify the vector file. If you are following with the samples, use the vector file C:\GeoWRSI\Samples\maps\mw_add.shp, specify that the "Feature Names Field" should be "PRIMARY,” then click "AutoGroup Now." Your form will look like the one below.
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Group by clustering
You can also group your data by clustering it using one or more of the water balance parameters. The k-means clustering algorithm is used. I suggest you use the "WRSIext_e" parameter, which is the WRSI at the end of the season. You also need to specify the number of clusters you want to create. If you are following along on the samples, click "Group by Clustering," select "WRSIext_e" as the clustering parameter, and specify 5 as the number of clusters to produce, then click OK. The clusters will be produced as below.
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The main disadvantage with the clusters is that one of the clusters will be one with very low correlation between all the administrative units and the yield, so you will not be able to define any meaningful relationship for that cluster.

Testing groups
You should test your groups before deciding whether to develop them further or to determine if there is a need to create new groups. To test the group, click on the group (the panel in the centre of the screen) and you will see the features in the group pop up in the panel on the right. Click the "Test group" button near the bottom right of the form, and the correlations between that group of administrative units and the yield (or whatever you are regressing against) will be shown for each water balance parameter that the model could find out of the ones that you specified earlier. If all the correlations are low, you may want to drop some features from that group or delete the group altogether.
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Developing the regressions
Once you are satisfied with the groups, click "Done." You will then get a form that looks like the one below. This form allows you to create the regressions. For each group, you can try adding different parameters to the model then click "Try Model." When you are satisfied with a particular group, you can click "Next" to move on to the next group. When you have finished developing models for all the groups, click "Save," then you can close.
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	Estimating Yield and Production
	




To estimate yield, you need to have developed the model first, described under the topic on developing regression models. You also need to have run the GeoWRSI for the year or season for which you want to estimate yields.

Select the "Run Model" option at the top right of the WBYE form. 

Specify all the options and parameters described on the form:
- the input working directory, which contains the outputs from the GeoWRSI water balance model run that will be used to estimate yields
- the output filename, which will be a file containing the water balance products summarized by administrative units
- the vector file of administrative boundaries
- the country administrative level and feature names field for the vector file
- the year for which to estimate yield (you can only estimate yield for one year at a time)
- the crop type for which to estimate yields

You should ensure that the model parameters that are being run are at least the same ones that were used in developing the regression models.

If you are following the examples with the samples folder, fill out your form so that it will be like the one below. The crop type should be the same as the one you used in developing the regression model, so if you developed the models for "maize," specify "Maize" as the crop type. 

When you have finished filling out the form, click "Process."
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You will get a report that looks like the one below. You can click "View Full Output," "View Summary," or "View CSV Format" to view different formats. You can save any of these reports by clicking "Save to File."


[image: image83]

If you have area data for the particular year which you have already imported into the database, you can also derive production estimates and include them on the report by clicking on the check box titled "Incorporate Area" at the bottom left of the report form. The results will be as shown below. A total production estimate will also be provided at the end of the report when the "Incorporate Area" button is checked.
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	Chapter 10. Theoretical Concepts of WRSI 
	




What is WRSI
The spatially explicit Water Requirements Satisfaction Index (WRSI) is an indicator of crop performance based on the availability of water to the crop during a growing season. 

In more technical terms, WRSI is the ratio of seasonal actual crop evapotranspiration (AETc) to the seasonal crop water requirement, which is the same as the potential crop evapotranspiration (PETc). 

The WRSI is an early warning and monitoring tool. Yield reduction estimates based on WRSI contribute to food security preparedness and planning. As a monitoring tool, the crop performance indicator can be assessed at the end of every 10-day period during the growing season. As an early warning tool, end-of-season crop performance can be estimated using long-term average meteorological data.

Development
FAO studies have shown that WRSI can be related to crop production using a linear yield-reduction function specific to a crop (FAO, 1977; FAO, 1979; FAO, 1986). More recently, Verdin and Klaver (2002) demonstrated a regional implementation of the FAO WRSI in a grid-cell based modeling environment for southern Africa. Senay and Verdin (2003) revised and extended the spatial implementation of the model in an operational mode to the rest of Africa, Central America, and Afghanistan.

WRSI for FEWS NET
Originally developed by FAO, the WRSI has been adapted and extended by USGS in a geospatial application to support FEWS NET monitoring requirements.

	Calculating WRSI
	




WRSI is the ratio of seasonal actual crop evapotranspiration (AETc) to the seasonal crop water requirement, which is the same as the potential crop evapotranspiration (PETc). PETc denotes crop specific potential evapotranspiration after an adjustment is made to the reference crop potential evapotranspiration (PET) by the use of appropriate crop coefficients (Kc). Kc values define the water use pattern of a crop. Published values (FAO, 1998) are available for critical points in a crop phenology, and intervening values are linearly interpolated. For example, maize Kc values are given as 0.3, 0.3, 1.20, 1.20, and 0.35 for the times corresponding to 0  percent, 16 percent, 44 percent, 76 percent, and 100 percent of LGP, respectively. 
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The water requirement of the crop (PETc) at a given time in the growing season is calculated by multiplying standard reference crop PET by the crop coefficient (Kc). 

                                    
[image: image86]                  (2) [image: image87]
AETc represents the actual amount of water withdrawn from the soil water reservoir (“bucket”) where shortfall relative to potential crop evapotranspiration (PETc) is calculated by a function that takes into consideration the amount of available soil water in the “bucket.” 

Soil water content (SW) is estimated through a simple mass balance equation where the total volume is defined by the WHC of the soil. SW is the amount of soil water present at a given time step. Its value varies from a minimum of 0 to a maximum equal to WHC (mm). Each time step’s new SW is obtained after determining the actual extraction by the crop (AETc). To determine AETc, dekadal rainfall (PPT) is first added to SW to produce a plant-available water (PAW) value: 
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Depending on the PAW in the “bucket,” the value of AETc is determined by the following set of functions (Senay and Verdin, 2003). (A schematic diagram of model components is shown in figure 1.) 

                        
[image: image89]                          When PAW >= SWC      (4) 

                        
[image: image90]             When PAW < SWC        (5) 

                        
[image: image91]                          When AETc > PAW       (6) 

SWC (mm) is the critical soil water level in the “bucket” below which AETc will be less than PETc. SWC varies by crop and growth stage according to the following equation: 
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SWf is the fraction of WHC that defines the available soil water level below which AETc becomes less than PETc during the mature stage of the crop (root depth fraction, or RDf , equal to 1). For corn, the SWf is 0.45; the literature reports that this value can be estimated as one minus the allowable depletion fraction (FAO, 1998). 

The root depth fraction, RDf, varies between 0 and 1 during the growing season. The effective root depth increases linearly from emergence until the mid-growing season when it attains effective depth for the remainder of the season. For maize, the effective root depth grows from a value of 0.1 m at emergence to a maximum of 0.9 m beginning at mid-season (after 44 percent of the growing season). The effective root depth is defined as 70 percent of the maximum crop root depth (Driessen and Konijn, 1992). The use of the root depth fraction is meant to simulate a young crop withstanding dry soil profiles (smaller SWC) thanks to light rain showers that replenish the upper root zone where the young crop’s roots are concentrated. 
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[image: image94]                  When SW > WHC (upper limit) (9) 

                        
[image: image95]                     When SW < 0.0 (lower limit)     (10) 

Where SW is the final soil water content at the end of simulation period, PPT is precipitation, and i is the time step index. 

	Components of a WRSI Model
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	Inputs to the Model
	




Precipitation and Evapotranspiration
The most important inputs to the model are precipitation and potential evapotranspiration (PET). 

FEWS NET at the USGS calculates daily PET values for Africa at 1.0-degree resolution from a 6-hourly numerical meteorological model output using the Penman-Monteith equation (Shuttleworth, 1992; Verdin and Klaver, 2002). Blended satellite-gage RFE images for the African continent are obtained from NOAA at 0.1-degree (~10-km) spatial resolution. Rainfall images are produced using an interpolation method that combines data from Meteosat cold cloud duration (CCD), the Special Sensor Microwave/Imager (SSM/I) of the Defense Meteorological Satellite Program, the Advanced Microwave Sounding Unit (AMSU) onboard the NOAA-15 polar orbiter, and reporting rain gage data from Global Telecommunication System (GTS) (Xie and Arkin, 1997). Precipitation prior to 1996 was obtained from the Collaborative Historical African Rainfall Model (Funk et al., 2003). The CHARM combines interpolated gage and reanalysis rainfall fields with estimates of terrain-induced precipitation. The WRSI model also uses relevant soil information from the FAO (1988) digital soils map and topographical parameters derived from Digital Elevation Model (DEM) data (HYDRO1k; Gesch and others, 1999). 
Start of season time (SOS) and End of season time (EOS)
WRSI calculation requires a start of season time (SOS) and end of season time (EOS) for each modeling grid-cell. Maps of these two variables are needed to define the spatial variation of the timing of the growing season and, consequently, the crop coefficient function, which defines the crop water use relative to a standard reference crop. The model determines the SOS using onset-of-rains based on simple precipitation accounting. (The time step of analysis is the dekad (WMO, 1992) whereby a month is divided into three parts, the first two are 10 days long and the last one completes the month.) The onset-of-rains is determined using a threshold amount and distribution of rainfall received in three consecutive dekads. In this model, SOS is established when there is at least 25 mm of rainfall in an initial dekad followed by a total of at least 20 mm of rainfall in the following two consecutive dekads. 

LGP (Length of Growing Period)
The length of growing period (LGP) for each pixel is determined by the persistence, on average, above a threshold value of a climatological ratio between rainfall and potential evapotranspiration. Thus, EOS was obtained by adding LGP to the SOS dekad for each grid cell. The WRSI model is capable of simulating different crop types whose seasonal water use pattern has been published in the form of a crop coefficient. Such crops include maize (corn), sorghum, millet, wheat, and rice. 

At the end of the crop growth cycle, or up to a certain dekad in the cycle, the respective sums of crop actual evapotranspiration (AETc) and crop potential evapotranspiration (PETc) are used to calculate WRSI (equation 1). A case of “no deficit” will result in a WRSI value of 100, which corresponds to the absence of yield reduction related to water deficit. A seasonal WRSI value less than 50 is regarded as a crop failure condition (Smith, 1992). 

Yield reduction estimates based on WRSI contribute to food security preparedness and planning. As a monitoring tool, the crop performance indicator can be assessed at the end of every 10-day period during the growing season. As an early warning tool, end-of-season crop performance can be estimated using long-term average meteorological data. 

Due to the difference in the growing season, WRSI maps are generated and distributed on a region-by-region basis (for example, the Sahel, southern Africa, Greater Horn of Africa regions). 

	Detailed Description of Current WRSI, Extended WRSI, and Soil Water Index
	




1. Current WRSI 

This map portrays WRSI values for a particular crop from the start of the growing season until this time period. It is based on the actual estimates of meteorological data to date. For example, if the cumulative crop water requirement up to this period was 200 mm and only 180 mm was supplied in the form of rainfall, the crop experienced a deficit of 20 mm during the period and thus the WRSI value will be ((180 / 200) * 100 = 90 percent). This approach is slightly different from the traditional FAO update where the cumulative supply-to-date is compared to the seasonal crop water requirement instead of the requirement up to the current period. Note that, unlike the FAO update, the current WRSI can increase in value in the later part of the growing season if the demand (crop water requirement) and supply (rainfall) relationship becomes favorable. However, both the FAO and this approach are mathematically equivalent when the end of season dekad becomes the current dekad. 

2. Extended WRSI 

This is a forecast estimate of WRSI at the end of the growing season. Long-term average climatological data are used to calculate WRSI for the period between the current dekad and the end of season. The calculation principles are the same as the “Current WRSI.” This is also a deficit-based estimate of WRSI. 

The long-term average PET and rainfall is extracted from FAO’s (1961–1990) long-term average monthly data (M. Bernardi, personal communication). Note that at the end of the growing season, only current-year PET and PPT are used as input. 

3. Soil Water Index
In addition, a third product (image) called “Soil Water Index” is produced as part of the suite of WRSI products. This image is a by-product of the WRSI model. The values in this image represent the amount of water stored in the crop root depth as a percentage of the WHC of the soil at the end of a particular dekad “i”: 
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where SW is soil water content and “i” is the time step index. 

Soil Water Index—Application
This index is an indicator of the soil moisture status at the end of a particular dekad. Therefore, it may be used as a tool to assess the crop water status in the next dekad based on the available moisture in the soil. The index is presented in four broad qualitative categories. For example, an index with 100 percent (“sufficient”) implies that there is enough soil water in the crop root zone to support the crop through the next dekad without experiencing water stress. A soil water index of “satisfactory” (60 – 99 percent) at the end of the dekad implies conditions ranging from some degree of stress (on the lower end) to areas with enough moisture to avoid crop stress in the next dekad. In the “stress” range (10–60 percent), the crop is likely to experience water stress (from severe to moderate) if there is no rainfall in the next dekad. In the “wilting” group (0–10 percent), the soil is already at a very low moisture level such that continued drought may cause wilting of the crop. The agronomic definition of wilting is when the soil water is at 0 percent of WHC; thus, the plant will avoid wilting if there is rainfall before moisture is completely depleted. Spatial association (proximity) of the classes can be used to identify areas that are in the low or high side of a given class. For example, within the “satisfactory” class those areas likely to experience stress will be found adjacent to the “stress” areas. 

This index can potentially be used for planning activities that rely on existing soil moisture conditions in combination with forecast rainfall. Such activities may include supplemental irrigation (for example, if current soil water index is very low and the rainfall forecast for the next dekad is negligible) or the identification and application of control measures for high-risk areas for malaria. 

Note: 

Soil water index (% WHC) is calculated only for areas where a crop is considered to be growing, that is, where there is a start of season in the WRSI calculation. A value of 100 percent represents that the soil is at least at field capacity (condition of soil moisture 2 to 3 days after a rain event that brings the soil water content to saturation). A value of 0.0 percent represents a soil moisture status at permanent wilting point. 

Soil water index is calculated for the current dekad only, with memory for soil water content carried from previous dekads via the soil water content parameter SWi-1. If the current dekad is after end of season, soil water extraction by the crop is minimal (low crop water requirement); this may result in a high soil water index value, even with a moderate amount of rainfall in that dekad. 

Unlike the WRSI, the soil water index does not provide information about the crop condition; however, crop water status for the next dekad may be inferred.
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	Chapter 11. Viewing Basic Rainfall Summaries 
	




Basic rainfall summaries can be viewed in the GeoWRSI, composited over different time periods. The program mainly works in multiples of dekads. Daily compositing is also possible, although this feature has not been extensively tested at daily intervals. The types of analyses that can be done include
· total current rainfall over a given time period

· total average rainfall over a given time period

· percentage of average rainfall

· difference from average rainfall
The flexibility of this module to composite over variable periods allows easier detection of dry spells and wet spells. Compositing can be done for all the different regions already defined within the GeoWRSI

To access the Basic Rainfall Summaries module, click on the menu sequence Tools > View Basic Rainfall Summaries. You will get a dialog box that looks like the one below:


[image: image98]
From this dialog box, you can specify the time period you want to analyze, the type of data you want to view (totals, average, percentage of average, or difference from average). By default, when the module is started, it automatically selects the dekad prior to the current date in the computer system.

You can also specify when your season starts, which allows you to quickly do a seasonal summary by instructing the module to summarize from the beginning of the season to present.

In addition, you can also choose the region that you want to analyze, selecting from all the regions already defined for the GeoWRSI

You can specify which vector maps to overlay on the rainfall map displayed, which folder to output the results to, and which mask file for masking out data that fall outside the area of interest. There are options on these 3 fields to use the GeoWRSI defaults, which are specified in the selected region and in other GeoWRSI settings. The default colours used are such that some of the values (for example, the near average values in the percent of average image) can be confused with areas that have been masked out. The mask used should coincide with national boundaries if possible to avoid this confusion.

You can specify an output prefix for the filename so that you will be easily able to recognize the outputs, which date and region they are for. By default, the module generates automatic prefixes for the filenames which specify the dates over which the analysis is valid for.

There is an option titled "1 dekad only". This option allows you to view one dekad at a time and to step backwards and forward in time examining the dekadal rainfall (or percentage or difference from average) one dekad at a time using the Show button and the left arrow and right arrow button on the dialog box. You can activate and deactivate this option by clicking on it.

The output from the analysis contains text showing the type of analysis, the period of analysis, and the region analyzed.

In the example shown above, the user specified that the percentage of average should be calculated for southern Africa for the period starting dekad 2 of December 2008 and ending dekad 1 of January 2009. The output from this analysis is shown below.
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The colors seen on the example shown above (reds, greens, browns etc), as well as the ranges of values used to identify the different colors are based on predefined color files that are specified in a file called rainfallsummaries.ini, which is located in the GeoWRSI settings folder. The specifications for these color files can be changed if a different color table and range of colors is required. This procedure is somewhat complex and beyond the scope of this manual.

Exercise

As an exercise, how many extensive dry spells of 30 days or more can you find between October 2007 and January 2008, in which less than 30% of rain fell? One period of wetness and dryness spanning at least 11 December 2008 to 10 January 2009 are shown in eastern Mozambique and northern Tanzania, and western South Africa in the map above.
	Chapter 12. Climatological Analysis 
	




Climatological analysis is possible for rainfall, evapotranspiration, WRSI, and Start of Season. This analysis is particularly useful if you have created a time series of improved rainfall estimates, and you need to provide a matching climatological context for viewing rainfall summaries such as percentage of average, or if you need to recalculate averages based on more recent data, or water balance data calculated using a different set of criteria. Other experimental techniques such as trend analysis are also available as part of the climatological analysis, though it should be noted that at the moment, the utility of some of the more advanced techniques such as the trend analysis have not yet been extensively tested.

In the sections below, the climatological analysis of rainfall and evapotranspiration is described first, followed by the climatological analysis of WRSI and Start of Season.

Climatological analysis of WRSI and Start of Season

Climatological analyses of WRSI and Start of Season can be carried out in the GeoWRSI. Analyses are region-specific and can be for different time periods, measured in seasons (for example, to calculate the median SOS for 2001/02 season to 2008/09 season). Analyses can only be done for regions and sasons for which the WRSI or SOS (depending on what needs to be analyzed) has already been calculated. For example, to calculate the average WRSI for 2001/02 season to 2008/09 season for southern Africa region, you need to have already calculated the WRSI for each of those seasons. 

The climatological analyses that can be done include:

· Average

· Median

· Standard deviation

· Range

· Count

· Coefficient of variation

· Trend

· Percentiles

To access the climatological analysis module for WRSI and SOS, click on the menu sequence Tools > WRSI Climatological Analysis.

When you run the module to calculate the average or median, you can select to automatically update the climatological WRSI or SOS for the selected region by clicking on the "Update Region Settings" option.
The following graphic shows a Start of Season analysis for the Southern Africa region that will calculate the median SOS for the 2001 season to the 2008 season. The outputs will not be used to update the Southern Africa region, since the “Update Region Settings” option is not set.
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In order to do the analysis, you need to specify the folder containing the WRSI outputs. These WRSI outputs should span a number of years, and are the data that you will use to calculate the statistics. If the data in the specified folder match up, exactly to the selected region, then you will get a list of years that you can choose that you want to analyze, corresponding to the years of available data. If the data does not match up, no options will be available in the "Select years to analyze" field, and you will not be able to do the analysis. If a prefix was used in the water balance analysis, this must also be specified in the text box "Output prefix that was used". If no prefix was used, leave this field blank. 
The result of doing the analysis above is shown in the map below.
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Optional Exercise

As an exercise, try analyzing the GeoWRSI data that is in C:\GeoWRSI\Samples\wbye\geowrsi_outputs. (specify this folder in the appropriate text box written “Specify folder with WRSI output data”). You will need to import the file Malawi2.region which is in the folder C:\GeoWRSI\Samples\region\ as a region (File > Import > Region File) so that you can do the climatological analysis. You will only be able to analyze WRSI data, as there is no SOS data in this folder. For Region, select “Malawi2”
Rainfall and Evapotranspiration Climatological Analysis

Climatological analyses of rainfall and evapotranspiration can be carried out in the GeoWRSI. Analyses are region-specific and by default, are done on a dekad by dekad basis, so that the statistics are calculated for each dekad in a list of selected dekads. For example, you can calculate the average rainfall for dekad 2 of February based on data from 1990 to 2005. In addition, you can also calculate statistics for summations over various time periods that you specify (for example, the standard deviation of total rainfall from 1 November to 31 December, over the years 1980 to 2000). When analyzing summations over various time periods, you also have the option to sum across years, which is useful when your season starts in one year and ends in the following year (for example, the season may start in October of one year and end in March of the following year). Analyses can only be done for data that has already been downloaded into GeoWRSI, and for regions that are completely covered by the available data.  
The climatological analyses that can be done include:
· Average
· Median
· Standard deviation
· Range
· Count
· Coefficient of variation
· Trend
· Percentiles
To access the climatological analysis module for rainfall and evapotranspiration, click on the menu sequence Tools > Rainfall Climatological Analysis. 
You can select to automatically update the climatological rainfall or PET for the selected region by clicking on the "Update GeoWRSI Averages" option. Note that the updated averages will cover the region specified in the analysis, so it is advisable to use this updating option only with the region that covers all the regions that you are going to use. For example, if you work with different countries in southern Africa, you would update GeoWRSI averages only while analyzing the Southern Africa region, rather than the region of any other country.
The following graphic shows a rainfall analysis for the Southern Africa region that will calculate the average rainfall based on the data between the 2001 and 2008 season for the 3 dekads of January dekad 1, January dekad 2, and January dekad 3. Three outputs will be created, one for each dekad. By default, the filenaming convention is pptKK.bil for rainfall, and petKK.bil for PET, where KK is the dekad of the year between 01 and 36. The outputs will not be used to update the GeoWRSI averages, since the "Update GeoWRSI Averages" option is not set.

[image: image102]
The data used to do the analysis is taken from the GeoWRSI data folder specified in the region file. The outputs will be placed in the folder specified in the dialog box above. A log file will also be generated specifying the location of the files generated. This will pop up as a message box on the screen as shown below.

[image: image103] 
When you do the analysis for only one dekad, the output will be shown as a map on the screen.

Calculating statistics for summations
You can calculate statistics for summations over various time periods that you specify by clicking on the "Add up seasonal totals" option. Once this option has been activated, you are given a second option to use a "July to June Sequence" of data. If you click this option, then your data will be arranged from July dekad 1 to June dekad 3 (of the following year). An example is shown below in which the average rainfall for the period December 1 (Dec_Dek1) to January 31 (Jan_Dek3) is calculated for the SADC Region.

[image: image104]
The output from this analysis is viewed as a map shown on the screen, and also saved to the output folder specified (in this case "C:\GeoWRSI\output". One output will be the statistic you specified (in this case, the average), but also the summations for each of the years specified in the analysis. The output for this example is shown below.

[image: image105]
Optional Exercise

For your exercise, carry out the steps outlined above using a region of your choice. You will need to import the rainfall and evapotranspiration data from the archives for 2001 to 2008 at least, if you have not done so already. You can use the menu sequence File > Import > GeoWRSI PPT Archive to Data Directory. Try looking at the outputs for different analysis methods, and try for single dekads, as well as for “Added up seasonal totals”.
.

	Appendices
	




	Troubleshooting
	


Some common problems that you may encounter are outlined below, along with ways of circumventing them.
1.         I cannot upload my data files

The GeoWRSI accepts ArcView type files which have only one band. 

The .hdr file should have at least the following information.

byteorder

nbits

xdim 

ydim 

ncols 

nrows 

nbands 

ulxmap 

ulymap 

Alternatively, you can use the type of header file that has an associated world file (.blw), because the GeoWRSI can read these files (new feature as of June 2006).

More information on the above parameters can be found in the ArcView 3.x help files.

Another reason you may not be able to upload your data files is that they are open in another program that may have opened them for exclusive access. In one case, the program could not read the water holding capacity file, and the model was not running. The file was already open in ArcGIS. After closing ArcGIS, the GeoWRSI read the file properly and ran the model.

2.         The program produces meaningless results when I run an SOS calculation

Check that your region files are correct (see the section on: Resetting the default region files) and that the median/average SOS file is correct. Check also that your ppt data directory contains current data.

Finally, make sure that you have all the data that you need to run the program for that particular season. Please note that the program requires six previous dekads of information before it is supposed to start according to the specifications in the region file. For example, assume that in your region file, you specify that the season begins in January dekad 3. The program will actually require information for six dekads before January dekad 3 so that it can initialize the soil moisture. So if you want to run the program for the 2003 season, for example,  you should also have data for Nov Dekad3, Dec Dekad1, Dec Dekad2, Dec Dekad3, Jan Dekad1, Jan Dekad2, in addition to the other data that runs through the season.

3. The IRE batch file is not running
Here are some common mistakes on the batch files that may make them not run.
- The suffix specification has no "." For example, if your grid files are in the format grid2007093.bil, then the suffix for this file is ".bil", not "bil".
- There are no quotation marks in a path that has spaces in it. If any file path has a space in it, the GeoWRSI requires that such a path should have quotation marks around it. 
For example, if your stations are in a folder c:\station files\, the incorrect command is
STATIONFOLDER c:\station files\.
The correct command is
STATIONFOLDER c:\station files\.
- The first and last column for the station dekads are incorrect. Check the DEK01TO36COLS parameter to make sure it correctly specifies the first and last column.

	What's New in Version 2
	




Improved Rainfall Estimation algorithm
· Methods for combining RFE with rain gage data

· Method for unbiasing RFE
· It is accessible under the Tools menu

Validation of Rainfall Estimates
· Rainfall estimates can now be compared with station data in a simple way, and scatterplots and summary statistics (such as correlation coefficient) are produced.

Downloading data directly from the Web
· Instead of doing a two-stage process to load data from the main server into the GeoWRSI, it is now possible to do this in one process.

· Previously you would need to first download the data from the server onto the computer, doing this outside of the GeoWRSI. Then you would go into the GeoWRSI and carry out the process of loading the data into the GeoWRSI.

· Now all you have to do is to go to the Tools menu, access the Download From Web option, and select the preferred option.

· It is also possible to instruct the program to download only the data you do not have in your system.

Viewing all available data
· You previously could view the data that you have loaded into the GeoWRSI by using Windows Explorer to go to the folder where your PPT and PET data are stored

· In Version 2.0, going to Tools > View Available Data allows you to check which data are available and which data are missing.

Online Help
· To enable you to make optimum use of the GeoWRSI, a "Help" system has been now included.

· To make maximum use of the available functions and capabilities within the GeoWRSI (most of which are designed to make the program easier and faster for you to use), take some time to go through some of the topics in the "Help."

· Many of the topics have been designed in such a way that you can read them in any order.

· The Help has also been structured to allow you to easily find information on any procedure that you may want to do
· In case the Help does not answer your question, please feel free to contact any of the support team members for further clarification.

Start of Season Anomaly image
· The "Start of Season Anomaly" map is now included as one of the image products.

· By clicking on the "SOS Anom" tab, you can view the map after the WRSI has been calculated.

· For an explanation of what "Start of Season Anomaly" refers to, please refer to the topic Outputs of the WRSI Model.

Tools menu
· A new menu item has been introduced. The Tools menu includes the following items:
· View Available Data 

· Download From Web 

· Batch Processing Assistant 

· Batch Processing Text Editor 

· Unbias Rainfall Estimates 

· Improve Many Rainfall Estimates 

· Validate Rainfall Estimates 

· Interpolate 

· View Basic Rainfall Summaries

· Water Balance Yield Estimator 

· WRSI Climatological Analysis

· Rainfall Climatological Analysis

· Extract Grid Statistics 

· Window Grids 

· View Spatial Data 

· View Map Table 

· Restore Default Program Settings 

· Clear Temporary Files

· Install Rainfall Unbiasing Files 

· Install Samples Folder
Batch Processing
Several processes can be run through writing code that will be processed. The WRSI and SOS can be run for several different seasons or scenarios from one click, running a batch file with instructions for the particular purpose.

Water Balance Yield Estimator
Producing yield regression equations and running those regressions to make yield estimates is now all possible within the GeoWRSI.
Viewing Basic Rainfall Summaries
Basic rainfall summaries can be viewed as maps, composited over different time periods. Summaries include total current rainfall over a given time period, total average rainfall over a given time period, percentage of average rainfall, and difference from average rainfall

Climatological Analysis of Rainfall, Evapotranspiration, WRSI, and SOS

Climatological analysis is possible for rainfall, evapotranspiration, WRSI, and Start of Season, allowing for analysis of average, median, standard deviation, range, count, coefficient of variation, trend and percentiles in data for various regions and over various periods of time.
	Changes to Version 2.00  
	




Some bugs that were addressed during production of version 2.0.

Version 2.00.00.34 - 04 July 2008
- fixed a bug that caused crashing when the user tried to save a batch file after having previously canceled the same batch file run in a previous operation
- improved error-handling routines and descriptive messages for error events to help the user diagnose the error better
- extended the shapefile reader to enable reading files of shapefiles with null shapes, thus preventing program crashing when such files are read, which was happening for some files
- extended grid statistics extraction (used in the WBPP) to be able to read floating point images, which are common outputs from the WBPP

- removed limitations that caused PET data of about 3 mm per dekad or less to be considered as erroneous data
- improved reading of input data such as WHC, LGP, and mask files to allow reading of a wide range of different bil file types (for example, 1-bit, 8-bit, and 16-bit)
- fixed the batch WRSI process to make it better match the manual runs
- fixed the display of map data from the WRSI run so that the legend is not drawn over by vector files
- improved the definition of analysis region extents so that it would be easier to define WRSI regions
- disabled editing of regions and crops and mask definition while model is running to prevent errors due to changes in setup definition during model runs

- fixed a bug that prevented proper ingestion and display of some floating point raster files
- fixed a bug on the module that defines the date in the batch text editor for the IRE routine
- removed bugs in the IRE process for developing IRE surfaces using monthly raster grids and dekadal station files
- improved analysis of IRE results by plotting of grid/station results and cross-validation results
- fixed a bug that caused the Batch Assistant to crash when it was reopened after closing it


Version 2.00.00.33 - 23 May 2008 
- fixed a cryptic error that would just print out "Image smaller than analysis area. Cannot load it up"; made it more specific so that the user has a better chance of fixing the problem
- added a link to the program data directory in the setup menu to allow more advanced users to tweak the GeoWRSI
- fixed a bug that was preventing saving of graphics when WRSI batch process was run


Version 2.00.00.32 beta - 17 April 2008
- fixed a bug that prevented the correct reading and displaying of regions spelled with a small first letter.

Version 2.00.00.31 beta - 3 April 2008
- fixed a bug so that diagnostic statistics in the IRE are correctly calculated
- fixed a bug to allow the correct conversion of vector-to raster for masks, SOS, LGP and WHC; this is now working correctly for shapefiles and bna files, as well as joined csv and dbf data tables
- fixed a bug to allow correct reading and drawing of multi-part polygons
- upgraded the diagnostic stats for interpolation to output shapefiles instead of bna files

Version 2.00.00.19 Beta - 28 February 2008
- fixed a bug in the batch component of the reading of the minimum stations parameter of the IRE routine
- improved the rate of display for the spatial viewer which also captures graphics done from the interpolation
- added a provision to add quotation marks to the batch filenames and paths whenever there is a space in the path to minimize runtime errors
- modified save-as and open functions so that they would default to the current file's path.
- fixed a bug that was preventing correct saving of existing batch files


Version 2.00.00.18 Beta - 13 February 2008
- fixed a bug to allow saving of graphics from the spatial viewer
- fixed a bug that caused region map and region files not to be updated when the region is changed
- incorporated max ratio into the IRE routine for single run and batch run

Version 2.00.00.17 Beta - 5 February 2008

- removal of bug to allow correct running of IRE with fclim or other average fields
- a semi-three-way cross-validation that compares how the data would have resulted if we had used an ordinary interpolation (with no-background grid) and what the predicted value would be at each station for an ordinary interpolation with that station removed (in all cases I saw, the IRE beat the interpolation by far)
- added ability to interpolate without a background grid



Version 2.00.00.16 Beta - 24 January 2008

- removal of several bugs, including 
     - correct calculation of WRSI during 0-rainfall
     - correct reading of MSB files
     - correct parsing of IRE batch files
- capability for downloading of PET and RFE directly from the adds, thereby eliminating the 7-day removal problem
- capture of graphics after IRE calculation
- spatial data viewer
- inclusion of advanced IRE parameter templates in the text editor menu
- ability to calculate series of IRE grids with average background grids
- ability to calculate series of IRE grids with the same background grid
   GeoWRSI Manual � INCLUDEPICTURE "mk:@MSITStore:C:\\visualstudio\\GeoWRSI%20Help%20and%20Training\\Help%20Source\\GeoWRSI.chm::/geowrsiintroductionb2.PNG" \* MERGEFORMATINET ���
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